Sansa Clip and Amarok

en I connect the Sansa clip via the USB cable …it mounts and I see the folders in my sansa…(podcasts, Music,…and stuff like that)…I dont see the Playlist folder…which I see in windows…but…more importantly…when I click in the Music Folder I odnt see any of the .mp3 files there should be at least like 330-380 songs in my sansa clip…i dont see any of them…I tried using amarok,…same thing happens. It shows me the folders…once I try to acces the folder…it says populating playlists and just doesnt give me any of teh songs…

It sounds like an MTP vs. MSC issue. If you have your Clip’s USB mode set to “Auto-detect” it will default to MTP mode when possible, and fall back to MSC mode if MTP doesn’t work.

NOTE: files transferred in MTP mode are “invisible” in MSC mode, and vice versa. The files currently on the player may have been loaded in MTP mode on a Windows PC, while Linux generally uses MSC.

i already tried that still didnt work…i posted this all on the openSUSE forum…and these were the replies so far…

"Check the USB settings on the Clip. Is it in MTP or MSC mode?  "

“also make sure show hidden files is checked sometimes there hidden”

My reply:

" i actually googled b4 even i posted this here…it was initially in auto-dettect mode…and the google links i

found told me to do it msc mode…which i tried and dint work…

Havoc…that didnt solve teh problem either…i tried the option of show hidden files…but no result."…

" Note that Sandisk lists Windows Media Player as a requirement for its Sansa line. Files transferred over in WMP may not be detected in other players or file managers. I had this experience with my E280 once and the ‘best’ solution at the time was to reformat it. If this is not possible, see if you can transfer the files to your hard drive in WMP. Be sure to switch to MSC (mass storage), and virtually any player will support the Clip. Mine works well in Banshee and Amarok."

 Sorry if I wasn’t clear, I meant to reformat the device, not the file format.

Sandisk has support forums with many Linux users. I’m sure this is a common problem, and you should get good suggestions from people there who have likely run into this many times. They may know a work around that I’m not aware of that won’t require erasing your files.

Sansa Clip Forum

If you find a solution there, please post it here, so other people with this problem can use it for reference. I’d be interested, as I’ve been using Sansa for years and couldn’t find a better solution than formatting.

This was the deiscussion so far,…

My clip is always in MSC mode.  Just brought up my Ubuntu 9.04 and Sansa opens fine. Dragged and dropped some music into music folder and all ok. I suspect you are having MSC/MTP problems. While I’ve no doubt people can and do navigate between the two of them, I think it’s one or the other. Drag and drop or use WMP. Mix and you’re going to have to work around the attendant problems.

If you intend to use Linux, then do everything in MSC mode. I don’t use Linux much. I used Audio Tag Tool to set tags, but it’s a dissapointment after using mp3tag in winxp.

Switch to the other USB mode (under Settings/USB), connect to your computer, and see if the “missing” tunes now appear.  If so, the tunes are split between MTP and MSC modes.  If that’s the case, I’d recommend:  on the Clip, switch to the USB mode you’re NOT going to use; connect to your computer and transfer the tunes you see to your computer; disconnect the Clip and switch to the other USB mode, the one you’re going to use; reconnect the Clip to your computer and transfer the tunes on your computer back to the Clip.

I advise against setting the Clip’s USB mode to Auto, as the Clip will try to connect in MTP mode and then, if that’s not posible, default to MSC mode.  In short, you won’t have 100% certainty as to the USB mode being used, and could have tunes under each.  Best, I think, to set to either MTP or MSC.  (Note that when you upgrade the Clip’s firmware, the USB setting may be reset to Auto.  Best to check and reset, if needed.)

I tried all possible methoods…MTP and  USB, then MSC…still not owkring…

Despite all the posts, including one of my own, I still am not clear as to what you are doing. You will only see files in MSC mode if they were put there in MSC mode. It sounds (but one can’t be sure) that you have had it on auto. On auto, it will default to MTP mode in winxp or later and MSC mode in Linux, since Linux doesn’t support MTP mode.

I would save all the files under windows using whatever works. Format the drive to unconditionally remove all files, set it to MSC mode and keep it there. If you want to use Linux you need to stay in MSC mode. If you use Linux, stay with drag and drop. I don’t use Linux enough to know about playlist support, but there are utilities to make these. You can even just use a text editor using a sample file as a template. I did this for a test but deleted since I haven’t found much use for playlists. The golist feature looks useful but I haven’t used that either.