Sansa Clip 8gb and Library Overdrive

Is anyone else having problems transferring overdrive files to ‘audiobooks’?

Initially I had to upgrade security settings in real player - that’s all done and now the files started transferring.

But I get one of two error messages.  If the files transfer without specific designation, I get told to synch to continue music subscription.   Not at all sure what I should be synching with as I do not want to listen to music!

If I transfer to audiofiles, then the odm licence to listen fails to arrive so I can’t listen anyway!

I have tried formatting, checked usb settings, and now can’t even get the files to transfer, getting an additional error message 

OverDrive Media Console Transfer Wizard
An error occurred while attempting to transfer “Witch Hunt-Part01.wma”.

Error details: Unable to transfer the selected title.
Error 0x8004500F: The license does not exist or has expired.


The licence is valid 14 days from today so that can’t be right either!

Any help that will let me use this device will be very welcome!


Welcome to the ugly, ugly world of DRM (Digital Rights Misery).  The problem is coming from Overdrive not seeing that the Clip is authorized. Because Sansas were originally to supposed to work with Rhapsody’s music subscription, the “music subscription” message actually means that your computer is not seeing your Clip as a device authorized to receive files. 

Try this. On the unit, go to Settings/System Settings/USB Mode and put it in MTP: Media Transfer Protocol, which transfers hidden licensing codes along with the files through programs like Overdrive, Windows Media Player, etc.

OK, now do this crazy thing. Open Windows Media Player on your computer–it has to be version 10 or above–and find, somewhere in its Settings (different in various versions) a place to un-check the box to Automatically Sync. (That’s so when ou connect the Clip it doesn’t start to dump everything onto the Clip.) Look in the Help files if it’s not obvious. 

Connect the Clip. Then pick a music file from your computer–any music file–and send it over via WMP. If you don’t want to keep it on the Clip you can delete it later.

What this should do is open the connection for those secret unlock codes and tell stupid Overdrive it can send over the books. Try it. 

If not, go step by step through Overdrive’s setup again:

You might also contact Overdrive or the person at your library who handles this. 

Thank you so much - I almost have no hair left and you have saved the final few tresses!

I now have a book ready to listen to!


You are a genius. I’ve called the library representatives for over a year, taken my PC in to the Microsoft store–nothing. I’d just about resigned myself to listening to MP3 audiobooks only. Your suggestions worked. I can’t believe it! I’m relieved. Thank you, thank you, thank you.