SanDiskSecureAccessV3_win synchronization not available?

I upgraded my SanDisk to use 3.02 Secure Access.
I want to use the synchronization feature, but it says upgrade required.
I followed the links and purchased the upgrade, but it appears to be a completely separate product and does not give me access to synchronize as I wanted.

Can anyone explain?