Sandisk ultra usb 3.0 64gb flash drive very slow

I have a new sandisk ultra 64 gb  usb 3 flash drive which is running at the same speed as a usb2.

I have a new computer with an “Asus H81M-Plus” mother board runing windows 8.1

Can anyone help with problem?

:smiley:   Hi ZuZook,

Dear User

 

1- I assume you have tried the UFD (unidad flash drive) on another PC, to define the problem.
2- I assume you have a Backup Data is in your UFD.

Well, seems defective, you must return it.

But, you can do the following test: 

3- The USB 3.0 UFD, have 9 pins (contacts) and 2 pins are for USB 2.0 compatibility.
Then you check, with a magnifying glass and flashlight, if these pines a_re dirty or broken or bent._
In Wikipedia, you can see, a graph with the provision of these pins, and which are 3.0 or 2.0.

Then, if is your PC:
4- In the “Control Panel”/Administrative Tools/Computer Management/Device Management Tools: see if a USB 3.0 icon is crossed out with red, or there is a yellow question mark, etc.

See, also, for a teaching with images, links:
http://kb.sandisk.com/app/answers/detail/a_id/10/session/L3RpbWUvMTM5Nzg0OTAwNC9zaWQvTnc3SVk2U2w%3D
http://kb.sandisk.com/app/answers/detail/a_id/8482
Luck.

Regards, Alfred.                                                      (Google translate)

 

 

Additionally, when you say slow, what’s the actual transfer speed that you get? From what I have observed, the bigger the file, the little slower it gets but not really that huge of a difference. 

:confounded:   Hmm… is there an echo, distorted… (and 4 days later…)

I have a similar problem.  I just bought several 16mb USB 3 flash drive, and don’t get faster than about 7 MB/sec when copying to them.  In adjacent usb3 port on my computer I get 80mb copy speed to an external HD.  When I put the flash drive in the other usb3 port I get the same result.

Do I just trash these or is there a solution?