SanDisk Ultra SDHC_8GB Sharing & Permissions problem - please help?!

hi guys

i’ve got a one year old panasonic lumix camera which came with a SanDisk Ultra SDHC_8GB memory card.

i’ve had no problems whatsoever with taking photos and downloading onto iPhoto (i have a Mac) but when i try to transfer photos from iPhoto onto the memory card it won’t let me.

i’ve tried taking the card out and unlocking it (NUMEROUS TIMES!) and even tried the flicking the grey thing up and down, wait 30 seconds thing and no luck.

when i right click on the camera icon thingy (i’m not very good with the jargon, sorry) which is called “no name”, then click on “get info”, under “sharing & permissions” it says “you can only read” 

(aaaaaaaggggghhhhhhhrrrrrr!!!) :angry:

can anyone help me please? 

i’m about to throw this bloody thing against the wall & i’m going to guess that it’s just something incredibly simple that i’m just not getting…

thanks for your time, looking forward to hearing from someone - soon!