SanDisk Ultra 64Go is very slow after benchmarking...


I have a SanDisk Ultra 64Go usb stick. I got it in September 2019 so it is not old. It was very fast, as advertised with 150mb/s in read speed. However, today I decided to benchmark it with AS SSD tool. Everything was going good (write/read speeds correct) but then it started something called “4K-64th”. And, now, it was at like 1mb/s and since the benchmark tool have to write 1gb and after read it… I could not wait for that :slight_smile: So, I decided to task kill the benchmark (the abort button was not working). I deleted the folder the tool created for its benchmarks. And, now, the jey is soooo slow. I tried benchmarking another time and now the read speed is 5mb/s !! :confounded:


I already tried formatting the drive, even deleting and creating partition but still very slow…

What did I do ???

Help please

Thanks and sorry for my english

I would suggest you write to AS SSD and ask them what their app did and how to fix your drive.

You could try writing to SanDisk and seek a replacement but to be fair the problem isn’t their fault.


Actually, it is really hard to contact AS SSD team because their software is everywhere on internet and I could not find the official web page so I could not find the developer email.

It is actually SanDisk fault. It would be AS SSD fault if I had’nt formatted the drive and even created a new partition. So, now, all changes the benchamrk wrote to the drive are erased… It is SanDisk fault because… I don’t maybe because their compenents broke or there was a failure…


Isn’t Alex Schepeljanski the author of AS SSD?

And while flash drives are solid state I’m not sure they qualify as SSD drives which is what the app was designed for.

Anyways, to see if SanDisk will replace your drive check out this link:

Did you try full format?