Sandisk Ultra 64GB , overheating and cracked !!!

Hi guys  , i purchased a Sandisk Ultra 64Gb  2 weeks ago , i have been using it fine for a week, yesterday i plugged the microsd into the SD adapter and plugged it into my laptop, the laptop took about 2 mins to detect it in Windows 8 but only as a hard drive, it would not open the drive nor could i see any files, 

after about 5 mins of messing about trying to get it to work ii gave up, when i tried to remove the card it was literally too hot for me to do so,  i have to power off my computer , wait a few minutes and then remove it ,i looked at the microsd and it now has a crack in the microsd, i am really just trying to find out if anybody else has had anything similar happen

i have been using memory cards for years and never had anything like this happen before, it could have been very dangerous and the outcome far worse.

1 Like

I’ve been around here for a while, and have never heard of this before. Could either be a defective card or the SD adaptor itself that fried the card. :cry:

Hi Tapeworm, thanks for your reply, i am going to contact the people i purchased it from, see what they have to say, it could have been extremely dangerous., i have just inserted the microsd into the sd adapter again this morning and plugged it into the is doing to exact same thing, regarding heat so they can have a look for themselves at the problem

I had same problem with 64 mobile ultra.
Very hazardous. Could burn and create a fire.
San disk be careful.

I have the exact same issue, im using a 32gb for the Raspberry Pi , worked fine for some weeks. Then suddenly it wont boot.

I burned my fingers on de SD-Slot. When it cooled down i took it out and it was slighty bend, wit a fine crack on the top. The card is useless at the moment. Im afraid to use the 64 one in my drone . 

Who has the same experience , with a faulty overheating card ?

Had the same issue with the 64gb Mobile Ultra micro SD and can’t get my tablet working again: it overheats with any computer/adaptor/laptop. Can’t even format it. Daren’t put it in my phone. Has anyone in Sandisk admitted to this rather serious fault?