Sandisk Ultra 32GB Problem with my Galaxy S4

Hi All,

I recently bought a new MicroSD Sandisk Ultra 32GB (For Android Mobiles, 30MBs).

Eversince I started using the card, I am unable to use the default Android image gallery as it keeps throwing an error ( stopped responding. This is annoying as I cant view images after I take them using the camera and I have to use Google Photos instead.

My phone would accasionaly freeze for a few sec then popup the error ( stopped responding.

Ive read around that this is a problem with the Sandisk Ultra compatability with Galaxy S4 specifically and they had it fixed in the new manufactured cards however I bought mine 2 weeks ago so not sure it was from an old batch.

Ive tried formatting the card FAT32 but still. My other Kingstone 16GB works fine and another Kingstone 32GB but is not class 10.

Any ideas what can be done?



I guess there’s nothing else much to do if you have reformatted this already. Have you tried to inquire if it’s still under warranty?