Sandisk ultra 256 gb - writing speed 0 MB/S randomly

Hello everybody

I have bought one month ago a 256 gb pendrive sandisk ultra usb 3.0 (100 mb/s reading speed) in amazon (therefore it is supousedly original).

I have encrypted it with bitlocker.

When writing, it starts writing at speeds (variable) of up to 10 MB/s, but randomly, every five seconds or so, it starts to write slower until it stops for a few seconds (writing speed 0 mb/s), and then it starts again. 

I did a chkdsk and retur errors in several cluters in a folder.

After that I deleted that folder and wrote again it. After that I ran again chkdsk and delivered 0 errors, but anyhow, it continues with the behaviour of stopping wrtting very frequently.

This is done regardless the usb plug of the computer I use, and I have tested it in other two computers as well with the same result (speeds of 0 MB/S in writting very frequently).

If I try with other pendrive I have (encrypted with bitlocker too, in the same computer, and in the same usb plug) writting the same folder, it doesn’t stop at all and the writting speed is, in average, about 10-15 MB/s.

Is this normal? Can I trust in this pendrive?

If I return it, and they give me a new one of this model, Can I trust in this pendrive?

As I have bought it in amazon, I might be able to return it and buy other model, or other brand, but if my case is isolate, I would like to keep it or have another of the same model. For me is important to have a trustable drive.

I can return it to amazon before 15th of february. If not, It would be sandisk who should deal with the faulty drive.

What do you think?

I think it would be interesting to test the write speeds without bitlocker.


   I would like to contact you outside of this post. I have some questions for you that are not exactly in the context of the thred. You you be willing to converse outside of this thread and if so, what would you prefer be best way to get in touch with you?