SanDisk Sport will not charge

When I plug my Sport into the charger, it says Low Battery. I can get the battery icon moving and showing that its charging like normal. After a short while, the movement stops and it shows that its fully charged but its actually not. When I unplug it from the charger, it will not turn on or respond no matter how long I hold down the center button.

When I plug it back into the charger, it says Low Battery again. No matter how long I keep it plugged in, it does not actually charge. When I connect it to the computer, it has power and can transfer music just fine. The battery just cant get charged for some reason. Never had this problem before.

Is the battery dead or something? The device is pretty old. Is there anything I can do to fix it?

Here is one older suggestion to try. Connect your player to the micro USB cable. Just before plugging the other end of the cable into the USB port of your computer, press and hold down on the large oval button. Maybe try holding this button for 30 secs after you connect the cable to your computer USB port.

1 Like

Thanks for the suggestion but it didnt help. One other thing is after I eject the player from my computer, the battery icon has a red outline while its still plugged in and its not moving like its being charged like it does when plugged into the wall charger.

I am sorry that I was not able to help. I think the cost of a replacement battery may be half of the cost of a new player (look at Clip Jam). And the battery exchange process looks a bit tricky. YouTube video. If We Can Do It, So Can You - Sansa Clip+ Battery Replacement - YouTube

1 Like

Thanks for the tip! Not sure I’m up for that so I’ll probably just look for a new player. Something wireless this time. From my research so far, the options don’t seem so good. The Sport Plus would be nice if it had a card slot. But I’ve also heard the Bluetooth is spotty as well. Any other possible recommendations, anyone?

My Sansa Sport was dead for several years, wouldn’t charge, wouldn’t start. I tried dfeld2005’s trick with pressing the oval button when connecting to the computer - and voila, it started! However, it wouldn’t charge even after a few hours. Didn’t think more about it, battery probably would have to be replaced, and turned the computer off in the evening.

Next day I turned the computer on (the Sport was still connected), and worked for a bit. Then I saw the Sport and wanted to disconnect it - and saw that it was fully loaded! Sure made me happy. Maybe something to try.