SanDisk SecureAccess 2.0

when you get the error

The application can not add more files because the vault’s disk is full.

check that your file names do not use reserved characters. take a look here for a list of such characters

do not hit the ok button on the error message, rather drag that error box a little bit and behind it you will see the progress box which shows file name and some other info.  this is the file that is causing the error.  if the file name uses reserved chars, rename the file and try again to put it in the vault. 

"Microsoft Visual C++ Runtime library

Runtime error

This application has requested the runtime to terminate it in a unusal way. Please contact the application’s support team for more information."

I get this error each time I tried to encrypt a certain amount of data. These folders were all in V1 but since I “upgraded” I get this frustrating error which limits me using the full capacity of the drive. Basically, it is a 32GB drive and only 9GB is in use…when I try to add the other folder which is 9 GB in total I get the error. When it does occur, even after restarting n o other file regardless of size can be added to the vault since the runtime error appears immediately. I have to save all the data already saved to the drive back to the PC and then delete the Vault. I have done this probably 8 times over the weekend in different sequences…same error. Wasted about 10 hours of my time.  The tech really need to address this error urgently. This is a serious issue. I am using Windows 7 and version 1 worked OK except for the annoying issue of not being able to edit items in the vault directly. URGENT HELP REQUIRED PLEASE.

Let me add that I can copy all the files to the open drive unencryted without issue. The issue is using secure access v2.

Why would it be a filename error when the file was in v1 and being copied into v2?  Looks like you have the same issue with Window and Mac.  You guys need to get this fixed ASAP.  Still pissed I lost all my photos from years.  Like I said in a previous post make sure you have a back up of the back and only drag groups of files at time instead all of them at once.

I get the same problem.  I would like v2 to edit in the drive, but it looks like I will have to return to v1

not only can i not access the new version & no one gets to back to you…maybe everyone is leaving sandisk since no one really needs it anymore with the “cloud”…first goes customer care

I filled my vault with the maximum amount of Gbits and never had any issues. I really feel safe running around with my data.

I have tried every suggestion, including starting from scratch with a formatted drive.  Same problem – it dies when I try to add a larger folder to the vault.  This is simply maddening.  There’s almost 100GB left and it dies with an error message of not enough space.  I really regret buying this product!

do you have a single file in the folder that is larger than 4GB? if so you will need to reformat the drive using exFAT file system. FAT32 file system does not support single files larger than 4GB. 

It’s already formatted in exFAT.  When it halts with that error message,and I view the drive in My Computer, all it shows is ‘exFAT’ – and it shows no unused space.  It doesn’t want to ‘eject’ like a regular USB accessory, so I just shut the machine down, remove the USB drive, and restart.  From there, whe I start the SecureAccess2, it’s seemingly back to normal – but NONE of the files I was trying to move are present.  This software is about as unreliable as it gets, and it uses up gobs of my time.  There just has to be a better solution.

I am having the same problem…did you ever figure out a resolution?  I am not able to save any new files to the disk because of the C++ Runtime Library Error.    

DO NOT TRUST SanDisk SecureAccess V2.0 with your data.

I’m having the same issue.  When I copy a large file, or a series of large files, the SanDisk SecureAccess V2.0 application crashes with a C++ runtime error and corrupts my vault – making my data impossible to access. 

After the crash, I get this error when trying to access my vault:  “The vault could not be loaded, it may be located on another computer or the original vault file has been manually removed.”  Of course, the vault has not been removed from the disk.

This makes my thumdrive pretty much useless, as I don’t trust it as a backup, which is wanted to use it for. 

I bought this drive because my company requires data to be encrypted at AES128 or higher.  However, I can’t trust the app with my data.

SanDisk AES-128 encryption = fail.


  • OS is Windows 7.
  • Product is 128GB SanDisk Cruzer Glide (SDCZ60-128G).
  • Running SanDiskSecureAccessV2_win.exe (build 5.4.7W, dated 09/10/2013).

EXTREMELY disappointed in SanDisk over this product.  Hopefully someone can help or they can correct the software.

ok, i like the article very good, it can help me,


thankk you very much

we can offer OEM usb flash drive

The same problem is here. SanDisk has tied my all the important files in its useless program, now i can’t reach to my truly important files for 10 days.

If they will not find a solution for this, i will surely sue them.


@tjrr wrote:

If they will not find a solution for this, i will surely sue them.

If you have the means to sue them, you should.  They’ve created encryption software that’s a toy, at best.  It’s not capable of encrypting the amount of data that can be stored on any of the sizes they offer this thumb drive in without crashing.



I have a large amount of data on my san disk.

When I copy back LARGE FOLDERS from my sandisk to my PC it fails.

If I break down the LARGE FOLDERS and do it my smaller sub folders and files it works!!!

This is really poor.

I have tried thie on 3 seperate 64 bit PC’s, windows 7 and 8.

I decided to remove for two main reasons:

-it is “too visible”.

I am using another sw, free, everything encrypted in one file, the name of the file could be … any (discreet).

Decoding sw could be elsewhere.

-I want copy my data anywhere and open it - it is impossible with sandisk sw.


I am facing same runtime error since i tired to copy large data to my new USB.

To my shock, since then I am unable to copy even a single file. can some let me know what to do now?


I have an Ultra Fit 64GB and was using it with my Surface Pro 3. To free up my USB port, I have bought an Ultra 128GB micro xdcard and is planning to use it on my Surface Pro 3 with SecureAccess 2.0.

Question… there seems to be 2 versions downloaded from your website. Would you be able to advise if they are the same and which is the correct version to use? Other than a minor differences in filename, there is a small size difference of about 6kb…

-  SanDiskSecureAccessV2_win   7,591kb

-  sandisksecureaccessv2-win      7,585kb


Andy Lee