Sandisk sd8snat-128g-1012 drive in M.2 to SATA adapter not seen by any computers

I bought a Dell laptop with a Sandisk sd8snat-128g-1012 and I have upgraded to a larger M.2 SATA SSD drive, installed Windows, no problems. I wanted to use the Sandisk 128 GB in an older laptop replacing a “spinning” 2.5 SATA drive. I bought two M.2 to SATA adapters (package deal) however none of the computers sees the Sandisk drive in the adapter: installation DVD or USB will not see the disk, not even BIOS detects the disk. The drive seems to sit perfectly in the M.2 to SATA adapter and there is only one way it can be inserted. Drive (and computers) are compatible with SATA III, II and I.
So far I have tried:

  • directly in SATA connector in 2 laptops and 2 desktops
  • in 2 external SATA to USB external drive enclosures
  • all the above with 2 different M2 to SATA adapters
  • after all the above, the SSD still works only when I put it back in the M.2 slot of the original Dell laptop, but still not recognized as a SATA drive when inserted in M.2 to SATA adapters
    With a multimeter, I checked the M2 to SATA adapters:
  • there is 3.3V present at pins 2, 4 , 70, 72, 74 of the M.2 connector
  • Ground gets to the SSD (PCB around the screw)
  • SATA A+ A- B+ B- pins get to the pins 49, 47, 43, 41 of the M.2 connector
  • pin 38 DEVSLP is connected to GND
    Everything looks fine, why is the drive not recognized?
    Am I missing some “detection” or “enable” pin at M.2 connector that needs to be connected to + or GND just for this Sandisk drive ?
    On the other drive PCB, I see pins 70, 72, 74 shorted together (3.3V) but on sd8snat-128g-1012 drive pin 70 is not connected to 74 and 72 on the PCB; maybe Sandisk has a new function for pin 70?