Sandisk Flashdrives not working

I just purchased two new Sandisk flash drives which works perfectly on all other computers but mine.

The drives show up on my ocmputer but has 0 bytes, I can’t format or do anything on there. I’ve tried deleting certain registry files, rebooting, and so on…but nothing has worked so far. 

It appears on device manager but not disk management so i can’t rename the drive either. Any idea how to fix this?

“up on my ocmputer”

Your personal computer or a company’s or university’s computer?

And what OS is your computer running, and the others you tried?

Company computer

It’s running windows 7 Professional 

We all have the same model of computer, with the same OS.

Talk to the company’s IT dept.  Your machine’s security configure may be preventing you from using removable drives.

We are a medical clinic…we have no IT department. But i’ll try reformatting and changing the settings. Thank you.

It’s possible a Windows Policy setting got changed, or some malware got on the machine, that’s causing the removable disk access problem.  Sorry I can’t be more specific.

(So tempted to say put a bandaide on it)

BTW It sounds like you are the IT dept. :wink:

Try to use the admin profile. I think you’re using a limited account here and mass storag might be disabled.

90% female clinic = no help in IT…

I"ll try running some more scans and if it could be the policy settings. I wish i could fix it with just a bandaid. Life would be so much easier. 

Already using admin profile. Other mass storage devices work (like my super cheap made in China 3usd ones)…just not sandisk. I think my computer just hates my new flash drives.

I wish i could fix it with just a bandaid. Life would be so much easier.”


Ok, what’s different with your machine?  Same brand/model as the others?  Same USB devices as the others?  Same antivirus as the others?  Same version of Windows as the others?

All our computers are same model, same windows version, everything is the same. I’ve just ended up using my colleagues computers to save my files or drag them onto the shared server.