Sandisk Extreme USB 3.0 Drive on Macbook Retina

Hi everybody,

today a got a Sandisk Extreme USB 3.0 64GB Flash Drive. I immediatly put it in my new Macbook Retina but it didn’t work. Didn’t recognize the stick. All other USB devices work great on my Macbook… I know that some USB 3.0 devices have problems with the new IvyBridge. Does somebody of you know more about that and how it will be fixed?!


I’m facing the same problem as you.

The new SanDisk Extreme USB 3.0 64G Flash Drive did not work with my MacBook Pro Retina (usb3.0), MacBook Pro 13"(usb2.0)  and even did not work with my iMac(usb2.0) !!!

I’ve contacted SanDisk’s CS and asked for help.

(I asked them to try this usb stick by themself and, curiously, they said they have no problem with it when put it in their mac computer!!)

It’s hard to believe.

They said they passed my case to their ‘related department’ and will let me know if they find solution.

I do want to know…anyone who can use this usb stick in his mac machine without problem?

I’ve contacted SanDisk’s CS and asked for help.”

What did Apple say when you contacted them about the driver not being on your MacBook?

I have the same problem on an iMac, which has only USB 2 ports. I bought the Cruzer Extreme USB 3.0 because on this page of the SanDisk site (specifications tab) it is stated that it is compatible with USB 2.0 and 3.0, although on the box it says “USB 3.0 required”. But, having bought the drive on line, I did not have the opportunity to read the fine print on the packaging. So I wonder whether the problem is with the Mac in general or it is an USB 2.0 port issue.


Has anybody contacted Apple, yet?

I tried it yesterday but no answer so far… hope there will be a software update SOON!!

I have same problems with 2 pieces of Sandisk Extreme USB 3.0 64GB Flash Drive. Spend 2 days trying all sorts of ways but still does not work. I was asked by Sandisk support line to go for an exhange but it does not solve the problem. I will still have a drive that does not work.

Tried the drive in Macbook Air 2011 (uSB 2) and Macbook pro 2012 retina (USB 3). Both on latest Mountain Lion OS. Cannot read/write/partition/format. Its supposed to be Mac compatible as stated by Sandisk. The original format exFAT is supposed to be workable. trying to pratition and format all failed.

Next decided use PC to format to NTFS (my Mac can still read NTFS thru drivers). Also failed with both XP and Windows 7 in both USB 2 and 3. PC convert/format to NTFS always fail. Can be formated back to exFAT which once connected to MAC will be corrupted.

Need expert help from Sandisk engineers on how to proceed. Thanks.

I have a MBP-Rrunning 10.8.2 and severalSandisk 64 and 32 GB USB 3 thumbdrives. They all work in my setup. I did have to reformat them and did so. I formatted my with the GUID partition scheme and Mac OS Extended (journalsed) format (as I use them for booting up as utility drives).

Mac also has a FAQ on USB 3 that might assist.