SanDisk Cruzer 32 GB flash drive issues

I purchased the flash drive from Amazon.  Put the device into my PC and tried to follow the user setup.  As soon as I plugged the drive in a message displayed on the screen saying the drive needed an upgrade, only option was to hit “OK” or exit the flashdrive.  There were no other options, menus, or any other available choices.  At no time did a set up widow appear, nor was there any way to get to it.  Third time through I hit ok, and the flash drive was upgraded.  It then asked for a password, which I never had a chance to set up.  Is there a generic password for the device after the upgrade is complete?  How do I fix this issue?

it sounds like you are running secure access. this is the password and encryption app. you do not need to use this if you do not want password protection. you can simply use the drive as a normal flash drive. if this is the case just delete all the files and use it as a normal flash drive. 

if you want to use password protection just delete all the file on the drive and download and install the latest version of secure access from the link below. 

- Download for PC (8MB)
- Download for Mac (13MB)

1 Like

That worked.  Thank you for the help