SanDisk 2TB Extreme Portable V2 SSD seems to be half speed on USB 3 ports

My new SanDisk 2TB Extreme Portable V2 1050MB/s SSD is reading and writing at around 300 MB/s on a Gen 1 USB 3 port and 600MB/s on a Gen 2 port but I thought Gen 1 USB would top out at 600MB/s and Gen 2 at 1.2GB/s.

|USB 2.0|April 2000|High Speed, also Hi-Speed|HS|480 Mbit/s (60 MB/s)|
|USB 3.0*|November 2008|SuperSpeed|SS|5 Gbit/s (625 MB/s)|
|USB 3.1 Gen 2|July 2013|SuperSpeed+|SS+|10 Gbit/s (1.25 GB/s)|

Hi @Tanquen,

In order to check speed of your flash drive we recommend you to please use below software to make a general assessment of your testing.
• To download the software, please refer to below link:
Windows: CrystalDiskMark
Mac: BlackMagic utility

• Run the file and Install the software by following the installation wizard.
• Once the software is installed, please locate the “CrystalDiskMark Application” icon on the desktop
• Double click the icon and then select the SanDisk flash drive in the Device box.
• Run the speed check read & write speed.
• Once this process will complete, share screenshot of test results with us on
• Disclaimer Notice: Use of Third-Party Software or Websites - Disclaimer Notice: Use of Third-Party Software or Websites


Seems like it should be closer to 625MB\s than that. It’s like 30%+ overhead?

The Extreme Portable model has a maximum speed of 550MB/s unless you have the Extreme V2 of 1050MB/s

If it were the old version that’s around 500 megabytes per second then getting 600 megabytes per second on a Gen 2 USB 3 port would be pretty impressive.

The maximum speed is 1050MB / s on USB 3.x Gen 2 (10Gbit/s), on 5Gbit/s ports the average is 450MB/s, that’s correct. The effective speed of the USB port is always lower.

USB 3.1 Gen 1 – SuperSpeed, 5 Gbit/s data signaling rate over 1 lane using 8b/10b encoding (effective 500 MB/s); the same as USB 3.0.

Yes the specs are in the OP.

You never get the real storage size or speed advertised on storage devices. I was just surprised that it’s 30% lower. Also, when I first tried to test I was only getting 300MB/s on Gen 1 and 600MB\s on Gen 2. Still not sure why.

Now on Gen 2 I get like 820MB\s and is lower that I would have thought and that is best case with a single large 15GB+ file.

If Gen 2 is really 1.25 GB/s, 820MB\s is like a 35% drop. :frowning:

In 3.x Gen 2 ports works at 1050MB/s, if you have lower speed you can optimize the operating system looking for what is slowing down your system such as antirivurs.

When doing speed tests keep in mind that the source disk must be equal to or faster than the destination SSD, otherwise it will only write the content of the cache fast and then it will go down to the maximum read speed that the source disk has .

Yeah, the test SSD is NVMe PIC 4.0 and rated at 7000MB\s so it should be good. It can copy to itself at like a real 2GB\s.

I just wish we did not have to play these games. It’s a computer, if you tell me your device can read data at 1050MB\s it should be my data, the data I want in a real file not the raw amount of data the transfer protocol including all overhead real or imagined. Not the MB vs MiB BS. Just the real sustained (an MB is 1024kB) MB\s to copy and large file.

1 Like