Problem with 'Albums', 'Artists' information of copied files on Clip+, Mac OS X


I recently was given a refurbished Clip+, with the latest firmware, AFAIK (01.02.15). I am using a Macbook Pro w/ Snow Leopard (10.6.7), and have been having an annoying problem with copying music files.
I apologize for the long post, but I want to be sure I am clear with the issues that I am having, as I haven’t seen these mentioned here, unless I missed something in my searching.


Single album folder copying results in multiple, oddly named albums each containing a portion of the original album’s songs


When I copy a music folder - ex: MYMACMUSICDIR/Led Zeppelin - III to the Clip+ /MUSIC directory, eject the player and look for the album using ‘Artists’, I see that often a single album from my laptop will be split across multiple ‘albums’ on the player, and across multiple ‘artists’ as well.

The separate ‘albums’ contain portions of the original album. Using the above example, when I copy my ‘Led Zeppelin - III’ folder to the Clip+,

What I EXPECT TO SEE - original mac ‘Led Zeppelin III’ album folder:

01 - Led Zeppelin - Immigrant Song.mp3

02 - Led Zeppelin - Friends.mp3

03 - Led Zeppelin - Celebration Day.mp3

04 - Led Zeppelin - Since I’ve Been Loving You.mp3

05 - Led Zeppelin - Out On The Tiles.mp3

06 - Led Zeppelin - Gallows Pole.mp3

07 - Led Zeppelin - Tangerine.mp3

08 - Led Zeppelin - That’s The Way.mp3

09 - Led Zeppelin - Bron-Y-Aur Stomp.mp3

010 - Led Zeppelin - Hats Off To (Roy) Harper.mp3

What I DO SEE - results under Clip+ ‘Albums’ listing, the following albums and songs:

‘Led Zeppelin III’

03 - Led Zeppelin - Celebration Day.mp3

05 - Led Zeppelin - Out On The Tiles.mp3

06 - Led Zeppelin - Gallows Pole.mp3

‘Led Zeppelin III|[’  

04 - Led Zeppelin - Since I’ve Been Loving You.mp30

10 - Led Zeppelin - Hats Off To (Roy) Harper.mp3

‘Led Zeppelin III|[’  (same corrupted title as above)

02 - Led Zeppelin - Friends.mp3

‘Led Zeppelin IIIdniwH’

07 - Led Zeppelin - Tangerine.mp3

08 - Led Zeppelin - That’s The Way.mp3

09 - Led Zeppelin - Bron-Y-Aur Stomp.mp3

For other source albums, sometimes the multiple ‘album’ directories are alsolisted among multiple ‘Artist’ entries, also with often corrupted names:

‘Led Zeppelin ~| [’<- not ‘Led Zeppelin’’

‘Led Zeppelin4’

‘Muse6| [ 10p/40’<- not ‘Muse’’

‘PortisheadO| [.’ <- not ‘Portishead’

First let me state that I have checked the following common OSX issues:

-My files are .mp3 (converted from iTunes .m4a), not AAC/m4a and play fine on my laptop and when selected on the Clip+.

-Not all copied albums have this problem, I’d say >3/4 do.

-Clip+ is in MSC mode-When I look at the folders in the Clip+ under OSX Finder, OR open a terminal and look at the mounted volume, all folders are normal.

-This seems to be a separate issue from the OSX ‘._’ duplicate files people are seeing

I’m thinking that it’s something wrong with the way the Sansa firmware generates Artist/Album lists - perhaps corrupted tags in the converted .mp3 file, resulting in different ‘artist’ and ‘album’ tag text from files ripped from the same album. Certain characters ‘[’, ‘|’ and numbers 4,8,0 seem to appear much more frequently.

When I view my music on the Clip+ by ‘Folders’, everything appears fine.

So while useable, this makes it harder to generate playlists, or listen to only albums of the same artist, etc.
I’ve tried formatting the Sansa, restoring factory settings, re-converting m4a->mp3 files, still get the same issues.
Has anyone else had this problem, and found a way to get around it (without re-ripping all of my music again)?

You could try using Kopymac, Internet freeware for transfering files from a Mac, that handles the odd circumstances that a Mac causes with PCs and non-Apple 3rd party devices like audio players and cameras.

I see that people reccommend that package often, but ALL software download sites that I could find (tried around 20 or so) link to the same file or domain:

and this appears to be a dead link. I cannot find any working links for this utility.

In any case, I’m not fully convinced it’s a simple OSX copying issue, since mounting the drive via unix and looking at things, everything is clean. I think it is an issue with the software that generates album and artist lists. 

I’m assuming that it’s looking for information in the .mp3 file tags created when a file is burned/converted. For some reason files converted from the same source folder on my HD may end up getting different/corrupted tag txt, which the Clip+ software, of course cannot verify which is ‘real’.

I’m going to try and find some mp3 editing software, or something that can look at the internal file properties (ID3 tags, etc.) and see if the source mp3’s themselves are the cause.

Available at CNET’s;1As many Mac users here can attest, Macs can do crazy things compatibility-wise.

Its available at CNET’s.:wink: 

@mikecorleone90 wrote:

Its available at CNET’s.:wink: 

Was this really necessary since a direct link was already provided in the post above yours?

I didn’t think so.

Please refrain from posting simply to rack up a higher post count under your name. It doesn’t benefit the community and is darned irritating!