Problem play larger m4a files.


I have been transferring some of my m4a music files to my SanDisk Clip Sport and have noticed that when playing back, the device skips over some of the files.  The m4a files that I have generated for use on the clip sport are all made using the same methods.  Some play and some dont.  The files that dont play seem to be files around 3900Kb or larger.  So basically anything around 4Kb in size or larger wont play.  This is the only thing I find in common about the files that wont play. Again, anything under 3900Kb in size plays fine.  Is there anyway I can get the device to play the larger files?  Is there something that I overlooking?

Best regards,


I find the Clip Sport player does really well with a wide variety of mp3 encoded files (128-320 kbps).

      I had mixed results with m4a files and I decided to abandon this choice to keep me & my Clip Sport happy.

Make sure you are using Clip Sport Firmware version 1.39 (or higher).

     The list of Bugs Fixed in FW 1.39 included this comment:   “Fixed the long duration m4a file playback”.

What software do you use to prepare your m4a files? 

     I think iTunes is a reliable choice?

Thank you I will check and update the firmware accordingly. I’ve been using Adobe Auditions. I got the package when I was in college and use the suite for all video and audio editing. I do believe the firmware update will solve my problems. Best regards to you.

Well I ran into a problem. I tried to update the firmware to version 1.43. It stuck at 90% and now it won’t turn on or do anything at all. What can I do now?