Problem on Android phone - Ultra MicroSD card 256Gb XC1 10 A1

On my Galaxy A40 phone I’ve been using this SD no problem for over 12 months… Now I started getting an error message that the SD card can’t be used properly so is being used ‘read only’. I put it into my PC to see if scanning it for errors would help. It said “you don’t need to scan it” (as it’s working OK) but gave the option to scan anyway, so I did.
The ‘progress bar’ of the scan quickly proceeds to the end, but then apparently freezes.
Please advise.
Thanks
[See below - what my phone shows.]

Did you back it up?
If yes, you can try unlocking the writing protection and see if it works then.

But really back up your data on the SD card. You may lose it if you do not do it.

and how do i do that?

by the way, i’m not sure that’s gonna help.
I tried unmounting the card on the phone, then re-mounting it. It started working again fine without any complaints, so obviously the write-protection was then removed for a while… but then after several days the same error message as above appeared again.

So if i manually switch off the write-protection as you advise, i think the phone’s soon gonna get suspicious again and turn it back on.

i think the next thing to try would be to reformat i guess… unless anyone can suggest something else?