Sandisk Mobile Ultra 64GB write protection error

I bought this card 4-6 months ago. It worked great since last week-two when I started to have problem with listening music etc (sometimes it stop or change music in the middle of the track). First I thought that its problem with Android and I need to reflash it or maybe headphones are broken, but when I reflash Android I’ve always format microsd and here is my problem - I cant do it!

Gparted on ubuntu gives me error with overriding partition (something like “this partition exist”) and after refresh everything is like it was earlier.

On windows i’ve tried sdformatter (write-protection error), easeus (close to gparted) and windows tool (it says that “device cant be format”).

Now I dont know what to do. I would like to “repair” it myself, but maybe its totally broken.

Any advice? Can I do something to make it usefull?


Too bad, dude. There is no way to fix the write protection error. You may call SanDisk to get a replacement.

I wasdreaming that someone reply: “U can use this or this app to repair it”, however thanks. I will contact them. Good that I can make a copy of data from it

1 Like