Playlists Not Recognized

I recently bought a refurbished Sansa Fuze 8GB from I had a 4GB Fuze that I was very happy with and that I managed using Rhapsody. When I got the new one, I was unable to drag and drop playlists into the new player, although I could move song files. After looking at the user’s manual, I tried using Windows Media Player to load the player. I tried to synch my playlists: the song files were loaded, but not the playlists themselves. I even tried copying the playlists to the player using Windows Explorer: The playlist files are visible on the player through Explorer, but when I select playlists on the player, nothing appears. Any help would be appreciated.


Are you using MTP mode?

What type of playlist formats are they?

I’m not sure which mode it’s in…whichever is the default when it’s first turned on.

The most recent playlists that I tried are just Windows Media playlists, although I had also tried to use playlists generated through Rhapsody.

I usually fiddle with playlists on my fuze by hand, i.e. using “vi” on linux. Several things I’ve found, one of which is that the lines in the playlist have to be in DOS format, i.e.terminated by a CRLF. If for any reason this is not so then the plalist file is there but the playlists themselves will show as empty on the mp3 player. If you’re running windows you can download  a “unix2dos.exe” command line utility which when run on the playlist files will ensure that there is a CRLF ending to each line.

Hope this helps.