Player not responding

I have used my Clip for about 2 months. I love it and have told everyone about it. I noticed the battery doesn’t last and I have upgraded my firmware. Also, I plugged my clip in to my computer and it won’t do anything, not even turn on. I tried different USB ports and different PC’s (not macs). I left if plugged in and still nothing. I also tried holding the middle button down and other button combos.

What do I do?


I don’t wanna make fun of your plight but I am sitting here with my player in my hand and it’s doing the same thing as yours so um kinna laughing a bit.

I just sent some mail off to them about the problem and hope that they can be of some service but frankly this kind of stuff does note bode well with me about their product.

If your player seems to be out of juice after 3-4 hours, then you need to replace your device.  Contact 1-866-SANDISK and let them know that your device is not holding a charge.  This is a known issue on a handful of Clips.

Go Sansa!