Pairing Bluetooth on my Sandisk Clip Sport

Hello I got this wireless bluetooth earphones neckband from Amazon which has noise cancelling function and can be work over 20hrs once finished charging, highly recommend

I’m also facing some bluetooth issues (Jabra Elite 65T earbuds).

While running, some cuts appear. Is this a known issue? Any fix to this?

So if I put it back to factory settings, will it erase my music?

@drlucky wrote:

I have an MPOW BT heaset and it work no problem with my clip sport plus. 


Try this


  1. Go to settings > Restore and restore the Clip Sport Plus to factory defaults
  1. Go to Bluetooth and turn Bluetooth on
  1. Put headphones in pairing mode
  1. Select Search devices 



@ineedhelpwthis wrote:

So if I put it back to factory settings, will it erase my music?


I have a feeling this is a problem with my speaker, but I could use some help. We have several Lenrue A2 Bluetooth speakers and have been thrilled with them. I can get the Sansa Sport Clip + to pair with only two of them. There is one where it pairs, but will not play. This sole tempermental speaker will play fine with other Bluetooth devices such as my Amazon Kindle Fire. But it won’t play from the Sport Clip. I’ve updated the Sport Clip to the 2.18 firmware and did the factory settings process. Does anyone have any other suggestions?

I have tried multiple of times with all kind of ways  to solve this; upgrade of firmware, reset, pair and unpair with the same result all the time that the connection works for a couple of minutes or up to 30 minutes and then the next day it’s repeat itself. It’s so frustrating to start the running excersie and then after a short while realize that it’s loosing connection to the media player. Since we all are experince the same or simillar issue and we have differnt headset it clearly has to be something with Sandisk Clip Sport Plus and a new firmware is clearly needed. Can we get any offical info from Sandisk regarding this issue?

Hi Folks

Trying to pair Blitwolf BW-FYE 2 Wireless Earbuds with my Sport Clip Plus

The device finds the eadbuds when I ‘search for devices’ but offers no option to connect ?

Iv’e tried with a friends different wireless earbuds and they connect fine

Is there a fix or firmware update for this apparently common issue ?



I’m stuck at this 

Any ideas how to connect please ?



It should just be to select it and then use the middle button. Have you upgraded to latest firmware?

Hi Fredeightyfour

Yes, I have the latest firmware, but when I press the middle button nothing happens and I eventually get a connection filaed message

Has any actually received a reply from SanDisk customer service relating to this issue ?
I emailed them but have had zero response

Hi Guys!

Same problem here, have the Clip Sport Plus. But it don’t want to pair with my bluetooth earbuds. The “Aiwa Prodigy Air” the player find them but won’t connect.

I tried it with the stock Firmware 2.18B & the new 2.20.B01 Firmware. On both it won’t connect to the Aiwa Prodigy Air earbuds.

Bluetooth speaker “Aiwa Exos-9” working and connecting flawlessly. See picture below:

Anybody tried the “JBL Tune 2200 TWS” already for working with the Clip Sport Plus?

Nothing with the Aiwa Prodigy Air…

Bluetooth speaker Philips BT55 working and connecting flawlessly.

2.20.B01? Where did you find that firmware?



They name it 2.20. But on the player it says 2.20.B01

Just tested the: AKG Y50BT working and connecting flawlessly.

And I continue…

Just tested my Edifier S350DB & Soundbar Teufel Cinebar 11. All working and connecting flawlessly.


Let’s see if this resolves anything of those issues I’m facing. My expectation of this update is quite low. One really anyoning thing is the volume popup message (with French answer) that comes everytime you raise the volume over 50%. I can get that there might be leagal reasons to have that, but it should be there once and then it doesn’t need to keeps comming everytime you have restarted the player.


I never had anything like that!? a volume popup? even on my old Clip Sport 8GB nothing like that. What language and region you put the player in? I set mine as the old one too language: English, and region to: North America

I’m not in America but c’mon I want the full volume experience


I know if you put it on other regions you get some volume limitations. Maybe that is some sort of your problem?