One track isn't playable, but it plays on PC.

So I have converted an album to OGG format and copied it to my Clip Zip.

All tracks play, except the last one.

The last one plays fine on PC, but when I try to play it on my Clip Zip in original firmware, then Clip Zip freezes. When I try to play it in Rockbox firmware, the track doesn’t freeze the player, but it just skips to the first track of the album.

Length of that track is 10:21, but that shouldn’t be an issue because I can play a track which is ~15 minutes long just fine.

I guess something is wrong with the file, but I converted it 5 times then copied it and it still doesn’t play.

It also doesn’t seem corrupted; MD5 checksums match for the file on HDD and the file on the Zip.

I tried using different bitrates, but that didn’t work.

How to fix it?

I can upload the file if it’s allowed on this forum.

MP3 format seems to play fine, other formats sometimes with glitches.  Perhaps try MP3?

I’ll use MP3 as a last resort.

Can this be because of tags?

@korn36 wrote:

I’ll use MP3 as a last resort.

Can this be because of tags?

Could be.

1 Like

I noticed some random garbage in “LYRICS” tag.

I’ll remove it and try to play the song.

EDIT: Still doesn’t play.

Nevermind, I had really huge cover art written directly into tags.

After removing it, the song plays fine.

Glad you found the problem. Yes, lyrics, anything in the Comments field or super-sized embeeded album art can cause issues with these things. :wink: