No performance gain whatsoever


I installed the SSD and the ExpressCache software, and although both seem operating normally, I didn’t notice any performance gain whatsoever.

I did everythin I found on the internet to try and solve it by myself, but nothing worked. Currently the ExpressCache software shows a 1.39GB cache (it’s been the same for 2 days now) and if I go to the Cache Monitor, it always show the blue line at the bottom most, at 0 at all times. (and the orange line keeps growing, as expected)

So, it seems like it’s not reading anything from the cache, and in the last couple of days it seems it’s not even updating the cache.

What should I do?

Have you actually been using the computer? The way readycache works is it will automatically copy the files needed for booting the system but anything else it caches is based off usage. It will identify the most used LBA’s and cache them to the SSD. If you are not using the computer there will be nothing for it to cache. 

You can test to see if you boot is faster by using a program called bootracer *(free download) run it first with the cache disabled to get a base line then enable cache and use bootracer to test the boot speed 4 to 5. You should see an increase in the boot time. 


I tried bootracer and it actually takes exactly the same amount of time to logon screen without the cache activated and after 4-5 reboots with the cache activated.

I did notice a slight improvement on loading startup programs (like dropbox and my mouse engine), but barely noticeable (2 or 3 seconds less).

The software also seems to be caching my torrents, because they’re obviously more frequently accessed than programs or system stuff. but that’s just plain dumb and useless. If we can’t chose which drives to cache, the software should AT LEAST be able to identify what’s important.

The bottomline is, for me, this purchase has been utterly useless. Is there any way to get my money back?


The retail version of the application is pretty limited in what you can configure. You can’t exclude specific files or drives. So if the torrents have a high read rate because they are constantly uploading this data will be cached. Nothing you can really do about that with the retail version of the software. 

That said I am not sure the torrent thing is the cause of the issue. If it were you should see a high number of cache reads. If the blue bar stays at the bottom it seems nothing is being read from the cache. 

Open the command line and run eccmd -info and post the results. We can see here what the lifetime reads and writes to the cache are. 

If you want a refund you will need to return it to the place of purchase provided you are within their return period. SanDisk does not provide refunds as they are the manufacturer not the reseller. 

Hi, here are the results:

ExpressCache Command Version
Copyright⌐ 2010-2012 Condusiv Technologies.
Date Time: 6/10/2013 16:11:54:792 (RAFAEL-PC #14)

EC Cache Info

Mounted : Yes
Partition Size : 29.82 GB
Reserved Size : 3.00 MB
Volume Size : 29.82 GB
Total Used Size : 11.32 GB
Total Free Space : 18.50 GB
Used Data Size : 11.24 GB
Used Data Size on Disk : 11.31 GB

Tiered Cache Stats

Memory in use : 1024.00 MB
Blocks in use : 8186
Read Percent : 2.30%

Cache Stats

Cache Volume Drive Number : 0
Total Read Count : 10302
Total Read Size : 254.70 MB
Total Cache Read Count : 30
Total Cache Read Size : 45.35 MB
Total Write Count : 24769
Total Write Size : 322.48 MB
Total Cache Write Count : 0
Total Cache Write Size : 0 Bytes

Cache Read Percent : 17.80%
Cache Write Percent : 0.00%

I’ve been using the computer nonstop for about a week now. I use it to work, play, watch stuff and I don’t even shut it down most of the time. I restarted it about 15 times in the last week just to try and see if EC starts working, to no avail.

It’s just not working as advertised, and this is pretty frustrating, since I could have bought a larger SSD for not much more, and decided to trust this solution because I didn’t want the hassle of reinstalling everything.

Still waiting…

From your last post it seemed you were returning the product. 

That said it looks like data is being cached and read from the RC SSD. What kind of computer do you have this connected to? Do you know what SATA generation the computer has? If it is not SATA 3 you will not see the full benefit of the product. 

That is not true. Computers can benefit from SSDs even if they have SATA 1 interface only. The gain the SSD provides isn’t in transfer rate but rather in seek times. Any computer engineer should know this.

That said, I’m using it in a year old system that does use SATA 3. I have 3 sata3 HDDs with a total of 6TB storage and that’s why I gave it a chance to the ReadyCache solution, since the advertisement says it speeds up everything and not only the system.

But it’s not working and after many days I still can’t see any performance gain.

What I said was on SATA 1 you would not see the full benefit of the product which is true as you would not see the full performance boost of the product. 

your usage pattern must be very strange, are you actually loading different programs every day of the week?