No longer powers on - Just "Low Battery Powering Down"

This is my second SanDisk m240 experiencing the same problem and now I’m really frustrated. The first time I thought the unit was faulty. Anyway, I replaced my old unit with a new m240 in July. It’s worked fine up until today. I used it for an hour, turned it off, and now I can’t turn it back on. All I get is a “Low Battery Powering Down” message.

I’ve tried numerous fresh batteries to no avail. The weird thing is that I plug it into my USB to get it to turn on and then unplug it. So now it’s running on the battery (a brand new battery I might add). Well, the unit immediately sucks ALL of the life out of the battery and cries for a new one.

What is going on with this thing? Does SanDisk just make inferior products? Unless I can figure out the problem, I’m done with this company.

Thanks in advance to anyone who can help.

Have you done firmware updates,etc?
Read all the info? Sandisk is good
about replying for support.

Click Here for Help

support@sandisk.com