My sandisk ultra usb 3.0 is write protected what to do?

It should be noted that with your approach, all files a user may have on the drive will be lost.

Users should consider filing a class action lawsuit against Sandisk. This issue is resolvable, but Sandisk refuses to address it, likely because they are profiting significantly from it.

A $500 contribution to the legal action case would be appreciated jahnsrichardd.

Ok I found the problem and fixed it. I found that when I plug in the USB through the device, it adds another free disk, so you can move the slot to switch to disk 3 (before it was working on disk 2). You can erase and format as usual.


i dont have the delete all partitions option

You have the Wipe Disk option which I can assure you deletes all of them.

Thank you for sharing information. :blush:

I forgot my password and needed to ‘factory reset’ my SanDisk SSD. I could not see the option to do this, and I tried what many on this forum did to no avail.
Here’s a step-by-step guide to resetting your drive:
Plug the drive in
Make sure you have downloaded the SanDisk Security app.
Search the app and right-click on it.
Select ‘Run as administrator’.
Enter the password incorrectly five times.
You will then be allowed to erase the drive and start over again.
Do not use SanDisk Unlock - you will not have the option to erase the drive
I hope this is helpful
Note: if you have forgotten your password, you cannot recover your files. I recommend setting a password hint.