my san disk clip is in a arabic language please help ! I need english

yes my sandisk clip, seems to have arabic, or some middle eastern langauge, please help I only speak english,  please I bearly got it 3 hours ago. thank you.

… power up that lil arabic speakin bad-boy by sliding up the power button on the left side, 'til it lights up. If it’s not at the main menu with some picture icons (Settings, Music, Voice, FM Radio), then press the ‘lil HOME button. Then scroll up or down to get to the SETTINGS menu (thats the one with the icon of four EQ switches on a board with animation of the 2 middle switches movin’ up and down). Press the middle button (or right   “>>I”  on the circular pad). You should be at the Settings menu, scroll up or down and highlight the LANGUAGE option. Best way to find it when set in any language on this menu… see an option that has some foreign text then FM? Thats the FM settings option, and the one above that is the LANGUAGE settings option, so highlight that one and press the middle button ( or right  “>>I” on the circular pad), and you should be in language menu. Just scroll up or down to ENGLISH and press the middle button ( or right “>>I” on the circular pad). HTH!

Btw, I don’t think it has arabic, you might be in chinese, korean, or thai language. :stuck_out_tongue: 

I had the same experience after I upgraded the firmware. The tech tried to walk me through resetting the language, but this didn’t work as there was only one language available (whatever it was – I didn’t recognize it).

We settled for attaching the player to the computer, then reformatting the device using Windows Explorer. (Right click on the “internal memory” folder, then select FORMAT).

This worked fine after the Sansa Clip rebooted; of course you lose all data on the Clip after the formatting.

I am having the same problem. My brand new Sansa Clip +4 is only in Arabic, which I recognize but cannot understand. I have tried resetting the language option described here as well as reformatting the device. Neither works. Any help would be greatly appreciated.

You also could try reapplying the latest firmware–see the firmware upgrade sticky thread at the top of the forum–which, if I recall correctly, asks you for the language to set.  (If I’m mis-recalling this, please let me know!)