My Radio not working!

Can someone please help me? The radio worked for about 6 months and now it won’t work…I really don’t know how to fix this problem and I really miss my radio.

@ella_beyya wrote:
Can someone please help me? The radio worked for about 6 months and now it won’t work…I really don’t know how to fix this problem and I really miss my radio.

Just out of curiosity…turn the radio on, and push up on the wheel…does it work then? :wink:

Nope. I happen not to be an idiot. I would have seen that, since that sign chances from green to red.

@ella_beyya wrote:
Nope. I happen not to be an idiot. I would have seen that, since that sign chances from green to red.

Well, I had to suggest it, since an amazing number of people have not been as enlightened as you. :stuck_out_tongue: Any other details you can give us would make the problem potentially easier to solve though.

My player is a 4 GB…though I only have about a GB of music on there. The radio will sometimes work for a couple of seconds right after I turn the player on. It worked for about a day when I reverted it to factory settings.

-Edit: I just reverted it back to factory settings and it didn’t bring the radio back to life :frowning:

Message Edited by ella_beyya on 01-15-2009 04:16 PM

Have you ever done the soft reset, holding the power button up for about 20 seconds?

nope, I’ll try it now.

is it supposed to turn the player off, or am I doing something wrong?

-edit; If I did it correctly, it didn’t help :frowning:

Message Edited by ella_beyya on 01-15-2009 04:44 PM

 Yes, it does turn the player off. ANd if it didn’t help, that sucks :cry:

Have you tried formatting it? It will erase the music you have put on it, but if the reset didn’t work, and this doesn’t work, then I would be fresh out of ideas.

@ella_beyya wrote:

is it supposed to turn the player off, or am I doing something wrong?

 

-edit; If I did it correctly, it didn’t help :frowning:

Message Edited by ella_beyya on 01-15-2009 04:44 PM

Did you try reloading the firmware?

I would try to do a format, but back up your music (unless your computer already has the music backed up, which is most likely to be true), and then a soft reset.

I formated it, which didn’t help in the least… How would I reload the Firmware?

I doubt very seriously if jumping through the hoops of formatting and firmware re-installation is going to solve your problem. The FM radio is on a separate chip inside the player, so these things aren’t going to matter to it. Besides you said it worked fine up until just recently. If everything else on the player still works correctly, then it seems to be a failure with the radio function.

I would advise calling SanDisk for an RMA # and get a replacement. You’ll start off with Tech Support and they’ll probably guide you through the things already suggested here, and if one of them works, GREAT! and I was wrong. But if they don’t work, then they will get you started on the replacement procedure. :smiley: