missing folders for laguage selection

I took delivery of a new Scandisk clip + 4Gb, took it out and fired it up and that was all I could do it was set in a foreign language,

looked like chinese, absolutely nothing can be done to change this.

Back in the box it went and straight back to Amazon.

Why do they sell these from china to any country without making sure that a language folder is available for the buyer to select their own laguage.

Had the folder been available, access would have been by opening the folder on a computer.

You don’t have to be a genius to to know, that in world wide trade you aint gonna sell many without a language folder.

  1. There is no “language folder”. This is not something you can change while connected to your computer.
  2. If it is a new unit, the first time you start it, it will ask you to select a Language, and then a Region.
  3. You can also change the Language at any time by going into Settings (equalizer icon) > System Settings (4th option down) > Language (4th option down) > English (1st or top option).
  4. If you had checked here or even the SanDisk Support page, you could have discovered this and saved yourself sending the unit back to Amazon and would be enjoying the player now. :wink:

Reloading the firmware will also bring you back to where you can rest the language.

It was a new one, it did not as you say, ask me to select a language or region.

do you not understand, everything in the window was in a foreign language so how can you select anything when you are

not able to read it.

I tried all options and nothing changed Guru!! 

have checked out the language and options, and find they would have helped.

but you would still be doing it “blind” surely there is an easier way than this?.

Simply reapply the latest firmware–see the firmware upgrade sticky thread at the top of the forum.