MacOS. Disk light is on, but drive will not mount, or show in Disk Utility. What now?

Model SDPS314-002T

At first, this light would go off and disconnect every time I touched the drive. With trial & error, I discovered that the cheap USB-C cable that shipped with the drive was bad.

I swapped out the cable, but the damage was done. Tried several cables, and different ports on different Macs. No luck.

Any saving this thing? Seriously disappointed in the quality of this product. I lost some important data.

I suggest running First Aid on the drive to see if it can be repaired. Otherwise, many data recovery tools can sometimes retrieve data from damaged drives.

1 Like

Thanks for the reply.

I forgot to mention that it doesn’t even show up in Disk Utility, so I can’t repair it.

I installed the SanDisk Recovery app and it couldn’t see the drive either.

Feels like the drive is fried, but willing to try anything to save it.

If the drive is still not working despite changing cables and ports, you might try using data recovery software or consult a professional data recovery service. If it’s still under warranty, consider reaching out to the manufacturer for support or replacement.
try using EaseUS Data Recovery Wizard. This software can help recover lost files from damaged drives. While the product quality is disappointing, EaseUS might be your best chance to save your important data.