Macbook Pro half speed

I’ve searched the internet and I know this is an issue. I have a MacBook Pro (15-inch, Mid 2009). I have had the SSD in the HD slot and in the optical bay with adpater. I’m only getting 210 MB/s Write and 264 MB/s Read.

I found that there are some other SanDisk drives that have firmware updates that can fix this. Does the Ultra II have anything like that? I tried installing Windows on the other harddrive and installed the Toolkit, but it said there were no updates.

Is there anything I can do to fix this? I can’t find anything to change or update ont he macbook end… I have already tried rebooting and SMC reset.

Any help would be appreciated!


i would like to inform you that Macbooks have the Trim function disabled nativelly so the ssd is not cleaned up. in that case you are loosing performance over the time and sometimes even freezing and bluescreens.

i would advise you to see if the trim function is enabled by a 3d party software, if its not then you can use the trimenabler to active it manually.

and for the firmware update for the ultra 2 i would like to inform you that till this time there is no other firmware you can update.

You can go to system information > Serial ATA here it will show you the Link speed of the SATA chipset and the negotiated link speed of the SSD. Not sure what SATA chipset a mid 2009 Macbook has but it is probably a 3Gb chipset. If you see 3Gb for both the link speed and the negotiated speed the SSD is linked up correctly. Nvidia chipsets have a problem linking at 3Gb and will only link with SSD at 1.5Gb. SanDisk release a FW that would lock the legacy Extreme SSD to 3Gb taking the negotiation away from the Nvidia chip set but since Apple nor Nvidia support that chipset any longer SanDisk has not released a similar FW for current SSDs.

As for TRIM how long has you been using the SSD? If it is new TRIM being disabled would not be the issue. If you ahve been using it for sometime with TRIM disabled (Apple disables TRIM for 3rd party SSD by default) the slower speed may be related to TRIM. You can enable TRIM using a TRIM enabler (googe search they are easy to find) if you have anything older than Yosemite. If you have Yosemite the TRIM enablers will not work. You can make them work but you have to disable Kext signing (a new security feature in Yosemite) before using the TRIM enabler. If you search how to enable TRIM in Yosemite there are instructions available. 

Last I have never seen any benchmarks for an SSD used in the optical bay so you may be maxing the speed out for that port. 

The drive is brand new. It was originally going in a desktop but I decided to try it in the macbook and get a bigger desktop drive.

The speeds are the same no matter where I put it, or even if I take out the optical drive and only have the SSD in the HD slot (Debunking the “splitting the 3 GB/s” response). I have tried everything. System information says 3 GB/s for everything. I`m sure it’s a Firmware/Software issue. I have done the restarts, PRAM, SMC reset, and all that fun. Not an expert, but not a newbie either.

It’s more annoying that critically needed. It’s basically my portable media machine. If I can find a drive or brand that will work with the macbook, I’ll just switch it out down the road. Still dissapointed that there is no current fix, though.

I have MacBook Pro 13-inch, Mid 2009. 2.53 GHz Core 2 Duo, 4GB Mem. Sata II (3 Gbit/s)

OS X 10.9.5 Mavericks with Chameleon to turn Trim on.

I have a 240 GB SanDisk Ultra II, the drive is only a few months old.

Blackmagic is reporting similar numbers to you;

Write: 186 MB/s, Read:262 MB/s with battery

Write: 208 MB/s, Read:264 MB/s with power

It is a Nvidia MCP79 AHCI Sata II (3 Gbit/s) Host Controller,  firmware will not make it a Sata III (6 Gbit/s) Host Controller.


this Nvidia MCP79 controller is known to have issues with Sandisk SSDs with various of issues from slower speeds and even freezing and not detected. so i suggest not to use this combination with your mac.

Is your advice on not using SanDisk SSD with the Nvidia MCP79 host controller based on fact, personal experience or just an opinion.

Are you able to be more specific?

My personal experience in using the The SanDisk Ultra II with Mavericks and Trim with the MCP79 controller has been very positive.

The SanDisk Ulta II has made the MacBook Pro usable again. Given the age of the MacBook Pro with only Sata II (3bit/s), the read/write performance of the Sandisk Ultra II is very good.

Please read my post on Tim and Yosemite topic.

I have had zero issues with the drive outside of not getting the full speed. The macbook I’m using it on is mostly just a media computer and something to use while my other computer is rendering.

While I’m dissapointed in the incompatibility, I have no problem waiting until I can get another drive that is compatable. It’s working fine in this machine, just not at optimal performance.

What incompatibility are you referring to?

There is no incompatibly at the SATA level, the Nvidia MCP79 Host controller is Sata II (3Gbit/s).

A firmware update on the SanDisk SSD is not going to change a the Nvidia MCP 79 Sata II Host controller into a Sata III Host Controller.

Apple don’t support third part SSDs, OS X disables TRIM when it sees a non Apple SSD. This is not incompatibility, it is Apple intentionally turning TRIM off.

I think it would help if we knew which one you had and what its spec’d out like. the unknown variables keep anyone from truly being able to give you some solid answers without making wild speculations.

@adomanim wrote:

I think it would help if we knew which one you had and what its spec’d out like. the unknown variables keep anyone from truly being able to give you some solid answers without making wild speculations.

Well said bro.

@adomanim wrote:

I think it would help if we knew which one you had and what its spec’d   out like. the unknown variables keep anyone from truly being able to kodi   [Lucky Patcher](http:// https://luckypatcher.camnox give you some solid answers without making wild speculations.


There is two way to resolve this issue -:
-> Youtube Videos
-> Macbook Contact page