m240 - Volume up stopped working

The other day my volume up stopped working. Turning the volume down is fine, everything else about the m240 works perfectly for me. I did a settings reset to get the volume back up to the original setting, but still no luck. I checked firmware upgrade. I am at 2.2.5A. Any suggestions? Its just pretty annoying not able to turn the volume up when needed. Any suggestions?

probably going to have to call 866.SanDisk. Sounds like something is physicaly wrong with the player.


  I realize this is an older post. I had this problem on my son’s M200 series player except it was volume down that was broken and it would only get louder. If you listen closely you can hear and feel the good switch make a little clicking sound and the bad switch does nothing.

  I had to pry open the snap together case and carefully re-solder the tiny surface mount volume micro-switch.  It had broken loose from the solder pads. If I remember right there was a tiny screw under the battery that I had to remove to get the case apart. Be careful with the switch buttons when you have it apart. You shouldn’t try this if you aren’t proficient at this type of work and you care about your warranty (I couldn’t find my receipt). This wasn’t all that easy and I’m an electronic technician. The case had a few cosmetic dings afterwards but was reusable and worked solidly.