Let Battery Run Out - Now won't recognize/charge on any PC

Title says it all.  I’ve been using my Sansa Clip mp3 player for months and never had a problem until now.  I accidentally let the battery run out completely while I was ont he treadmill yesterday.  Now whenever I try to connect it to one of my pcs, the screen pops up on the Sansa stating “Connected… Writing” then it disconnects and keeps repeating the same message.  The computer never recognizes the clip and the clip never charges.  Things I’ve tried thus far:

  1. Resetting it

  2. MTP USB Mode

  3. MSC USB Mode

  4. Tried to charge it on my Vista laptop (which previously worked perfectly before letting the battery run out)

  5. Tried to charge it on my winxp desktop (which previously worked perfectly before letting the battery run out)

I’m out of options.  Please tell me this isn’t an overlooked design flaw by Sansa and there is a way to fix this.  I can’t believe just because the battery ran out that I may not be able to use it again.

Have you tried forcing an MSC connection?  That sometimes seems to work.  (Clip off and in hold with the on switch all the way down so that the orange shows, hold the center button down as you connect to your computer.)  And you can try leaving the Clip connected to your computer overnight–that sometimes seems to work as well. 

Forcing the MSC connection didn’t work.  I’ll try just leaving it on overnight tonight connected to pc.

Leaving it on overnight didn’t work.  I guess I’m out of a mp3 player now.

Do me a favor and leave it plugged in for another day or 2; these things have a habit of sometimes coming back from the dead …

Also:  can you try charging it via your house AC and a USB AC adapter?

Message Edited by Miikerman on 10-15-2009 09:16 PM

Same thing happened to mine…tried everything listed in previous posts and still does not charge.  Screen shows “Connected…Writing” and then disconnects with no charging having been done

Update on my previous post…just plugged it into the USB port and now don’t even get the “Connected…Writing” screen.  Looks like this is on it’s way back to Amazon and won’t bother getting another Sansa product…a shame, because the radio function was great!

For whatever it’s worth, defective products sometimes get through.  You can RMA it through SanDisk and they’ll send you a replacement.  I’ve had no charging issue with mine. 

Thanks for the advice, but I have a really stupid question for you…what does RMA mean?  And how do I get the replacement?  Thanks

“Return merchandise authorization.”  Telephone SanDisk at its Customer Service phone number near you (in the U.S., it’s tollfree–just go to its website to find the numbers) and explain the issue.  The rep. may ask you to try various solutions.  If nothing works and you’re within the warranty period, they should issue you an RMA for you to return the player, and then they will send you a replacement once they receive the defective player.  If I recall correctly, at least in the U.S., they send you a pre-paid mailing label.

(And not a stupid question–you probably have been fortunate not to have gone through the RMA process before!)

SanDisk generally has been supportive as to player issues, as part of its customer service.

Same thing happened to me, the circumstances where slightly bit different, i have lost my original cable and i bought a belkin that fits perfect, my sansaclip didn’t run out of battery completely, however i reckon i am seeing the same message on my sansaclip screen “Writing…Connected…Writing… Disconnected” over and over again and will barely charge but i can’t transfer any mp3 file from my computer to my sansaclip on my OS (Vista) i can see how the sansa icon appears and disappears meaning the device has not been completely recognised by my computer (i have used the same pc on my sansa for ages and it worked properly before i lost my cable) Please tell how can i have this problem fixed, or i might have to buy another sansaclip device (i am really keen on them) and i am not precisely a computer techy but an avid sansaclip user. 

Thank you

Update: My sansaclip is back to life after putting it to charge for 7 hrs, then i restarted my computer and plugged the device back in… works fine now!

Thank you for your time.