iXpand flash drive go not showing all files

Hello and thank you for your help. I recently purchased a 256gb iXpand flash drive go to store a bunch of videos that I can’t fit on my phones internal memory from graduations, weddings, etc. I have copied all of the videos to a singlular folder of about 1600 files. When plugged into the computer I can see all the files are on the flash drive, however when I try to access them from the app on my iPhone, only 108 of the files show up. I have tried updating the firmware but the program can not find the flash drive, which is odd because the computer is able to access it. I have tried turning off and on my iPhone, ran a disk repair on the flash drive and several other solutions found online to no avail. I also left it plugged into my iPhone over night to see if the drive needed to be indexed, but after 8 hours, there was no change. 95% of the videos are in .mp4 format, which is supported according to the owners manual. The 108 files are also in .mp4 format. I have also tried several different iPhone apps, and they all list 108 files. My iPhone and app are up to date.

What could be causing this issue? And how do I view all my files on the flash drive from my phone?

Hi @Ptag,

Please contact the SD Technical Support team for best assistance and troubleshooting: