How to reset the password on Sandisk Cruzer Glide

My Cruzer Glide vault password was eleven characters long, and I now discovered it will only accept eight characters. One of the answers given was “have you reset your password?” It gives NO information on how to reset the password. I have about 10 gb files encrypted, but have no way to access them. Help?

Curious, how long have you been using it before it asked for your password?

What triggered the prompt to enter your password?

I assume you have entered the 1st 8 characters and it got rejected. Try the last 8 characters.

Also try, a glass a wine, a good night’s sleep and a hot shower in the morning. It’s amazing the things I remember in the morning shower.

I purchased this 16 gb Cruzer Glide a few weeks ago, and never used it until this first time. I concocted an eleven-digit password and wrote it down.I then went through the motions to enter the password in the vault set-up prompts, exactly as I wrote it down, then was asked to re-enter the password. PW was accepted and I began saving numerous files to the drive. The next day as I tried to access the files, the drive refused the PW or any permutation of it. I spent an hour trying everything I could to gain access to the drive, but with no success. I also did what you suggested, tried the first eight digits–no success; tried the last eight digits–no success. Please help. I can’t afford to lose those files. Is there any way to reset the PW? Thank you for any help you can give.

Something that caught me at work decades ago, I entered my password when the Caps Lock key was pressed. Needless to say it was rejected. I tried repeatedly and got annoyed. I called the head of security and theatened her! Then I figured out the problem. :hot_face:

Hopefully you have the same problem.

Another point, important files are backed up. Almost by definition. So should the password fail again, create a new drive and write the files from their backups to it. :wink: