How to remove 'READ ONLY' option from Dual USB Drive

My Sandisk Ultra Dual USB drive 3.0 is functioning normally, but am not able to format it due to its  ‘READ ONLY’ property, as shown by computer. Can someone plz suggest me how to remove this  ‘READ ONLY’ option, so that i can format the drive.  

If it is functioning normally why format it?  What format is it now?

Just go to properties and remove the deny option for ‘write’.

This video might help

I am having the dreaded “Read Only” problem on a variety of drives.

I have tried

Apacer Format Repair Utility (Free)

   Did not recognise my SanDisk SD card - it is for *USB drives* – but has worked to allow formatting of a stuck in Read only mode drive in the past.
HP Format Utility (Free)

   Did not work got to 7% and stopped, though it is the tool recommended by SanDisk
Authorsoft’s Format Utility nagware with $10 pro version untried)

  Stopped part way – all the way? – but in the past just runnig its check has fixed things.
Micrrosot Drive manager Start > Run > diskmgmt.msc
  Got to the end and then said could not finish.

I also tried deleting the partion using the command line (I deleted it but to no affect!)

There is alonger list here mentioning all the above and some I have not tried (NO affiliation)

I also have some free software called RMPrebUSB which has a write zeros to the boot area but I have not tried it.

Today toggling the write protection switch worked! This is bizzare since if it were the switch it should not have allowed me to format for x percent using the above tools. I don’t push the card into a Card reader slot but keep it in its own card reader which is tightly shut with a cap and electrical tape so I see no reason why the switch should have made any difference.

I am in Japan so I can’t send it to the USA. I very much doubt that there is anything wrong with the card or that the supplier would give me a new card after a couple of weeks. It cost 40$ since it is 128GB. It is the third external 128GB drive that I have bought this year and this is about the 5th time I have had a read only problem. I have been using external drives for many years but it is just in the past couple of years, and certainly since Windows 8

I wish SanDisk would create a cool diagnostic and repair tool that writes to everywhere and hard formats anything!

I use a disk ejector software to ensure that I really do eject the disk properly.
It seems good, and gives me a cheerful ejected message, but I got the read only problem again.

I can’t help thinkign that the prevalence of read only problems recently may have somethign to do with the fact that Microsoft has started selling cloud storage that it pushes from teh save Document area of its office products and sells bundled with Office 365. If MS makes more rules and Windows is more strict about what causes a drive to be put into Read Only mode then more peopel will need MS’s cloud services.I am not saying that they are deliberately being maliscious, but that there is no incentive for them to allow users a bit of leway if they are selling an alternative to external USB memory.

Try using the Windows Safely Remove function to remove USB drives and see if the read only problem goes away.