How do I get FLAC files onto the Clip

hi all


New 8GB Sansa Clip. All my music is ripped in FLAC using EAC. Plays no problem on Sonos and PC via MediaMonkey.


I can’t get files onto the Clip.


If I try drag-and-drop to the \media\music folder I get a message “Media Type not supported on this device”.


If I try to sync. via MediaMonkey I get the blank \Elbow\Leaders… folder created but no files.


According to the system info I have V02.01.16F


Also when the player is turned on it always goes to the Radio for some reason.


Any ideas?



Upgrade your firmware for FLAC support.  See the sticky at the top.

According to the sticky I already have the latest firmware.

The docs. with the player also state FLAC support.


I assume your music has the .flac extension.  Double check the revision of the firmware.  FLAC was added in the last version.

They are .flac files, yes.

I tried adding an explicit .flac to one track and got the same error.


Did you try MSC or MTP mode?  Settings>USBMode> Select MTP or MSC

I would apply the firmware update again.

Message Edited by sansafix on 12-17-2008 11:33 AM

Where is the MTP or MSC setting?


Fixed - I changed the USB setting to MSC mode from “Auto Select” and I can now drag and drop and sync. via MediaMonkey.