Home internet connection

i can’t get my 16G stick to connect to my home internet. All else works as expected.

i select my home network, enter my network password and the stick attempts to connect. It states the process could take 2-3 min. After about 1 min it states the stick can’t connect. Are there settings for my router that I need to check? Any other ideas?


what type of network encryption are you using on the home network? IIRC the wireless stick only supports WPA2-personal. If you have WEP or WPA or some other type of network encryption it will not connect. 

Hi drlucky, I checked my wireless setup.  I have a surfboard sbg6580 modem. The wireless security is set for WPA2-PSK with AES encryption. so that shouldn’t be the problem?  Any other thoughts?

Thanks for the help!

OK, I tried the drive on my neighbors network which is encrypted with WPA2-Personal.  No problem with connecting.  So my assumption that WPA2-PSK and WPA2-Personal are the same is incorrect.  I’ve contacted Arris to see if they have a solution to the problem.  I’ll keep you updated.


OK, I’ve contacted Arris and below is their response.

‘WPA2-Personal and WPA2-PSK are the same thing, just different terminology. For WPA2-Personal, you set up a Pre-Shared Key (or WiFi Security Key). WPA2-Enterprise uses RADIUS encryption. If you want to enable WPA version 1, you would just need to change it to WPA and WPA2, and then set the encryption to TKIP + AES on the Primary Network page.’

Of course I tried WPA with TKIP+AES as well with no success.  Not much help.

Is this an Arris issue or a SanDisk issue?  Any ideas on how to move forward?  You’d think WIFI is pretty mature now and these type of issues wouldn’t occur.


All right boys and girls, I’ve come up with a solution.  Albeit with some questions.  If I Disable ‘AP Isolate’ on the Arris AP I’m now able to connect the SanDisk Connect Wireless Stick to my home network.  From reading online, the AP Isolate function prevents multiple users on the network from accessing each others devices.  So I can see how this would be a problem when connecting the Wireless Stick.  But, I have an HP Wireless Printer connected to the network which can be accessed by multiple devices and it works just fine with this function ‘Enabled’.  So I’m a little stymied why this would be the issue?

Additionally, one minor but important point.  Some where in the SanDisk documentation it should be stated the router must be operated in WPA2-Personal Encryption mode (although this wasn’t the problem I was having).


glad you got it working and I can definitely see how AP isolation would prevent you from accessing the wireless stick over the network. 

my guess is that the printer is not using the same protocol as connecting to computers or servers over a network do so this is why AP isolation does not affect the printer. IIRC the wireless stick is using webdav for access over the network and is probably seen by your router as a server so AP isolation would prevent the communication to it. 

That’s a good point on the wireless printer.  It is a different protocol, if you think about it, it doesn’t show up as an AP even though it uses WLAN. Thanks for the input.

To properly give internet connectivity to my Lexmark printer, I have called to Lexmark support. And they provided me the steps to resolve this issue online.