Help with Windows Vista??

When I plug in my Sansa Clip into my usb, my computer does not recognize my device and will not install the driver from the enclosed disk.  When I go to Sansa’s web site there is no device driver to download. What do I do?  PLEASE HELP!!!

Format your device and then plug in PC again to see if it helps.

I am having the same issue.

I did reformat my CLIP (over and over and over), but this did not help. I also attempted to put the device in MSC mode by putting the device on hold and holding down the center button while I connected the USB cable. This did nothing. Then I read a post saying to hold the “rewind” button while connecting. This also did nothing. I am running firmware version 01.01.11A with VISTA and WMP10. I cannot upgrade the firmware on the CLIP since the OS will not recognize the device. I was able to get the CLIP to function properly, on a friends PC, using XP sp2, just by plugging the thing in!  I read, both in this forum,other forums, and the product site, that the CLIP would work with VISTA. I used these posts and descriptions in making my decision to purchase this “device”. I wonder if those, that stated it would work with VISTA, actually connected it to a VISTA machine or were they just spouting company marketing propaganda. If someone did manage to actually get the device to work with VISTA, please inform the rest of us as to how this is to be acomplished. If a driver is needed, please inform us what price we must pay to the Sandisk Gods to get them to provide it (as if the purchase price wasn’t enough). If this complete lack of support is reflective of what Sandisk thinks of its customer base, you can be assured that I will never purchase another product bearing their name.

Please, if anyone else has had this same experience, speak up. If someone has the solution, I’m all ears.

Now, if you can get the device to work on your friend’s XP…then why don’t you use your friend XP to upgrade to the latest firmware…then go the settings and choose MSC mode and plug in your Vista to see if it works.  Also, make sure the cable is properly plugged in your device, you need to push it in hard enough so there is connection or else it won’t work either.  Try update the firmware first and see what happens next.

Thanks for the advise. I’ll give your suggestion a shot and I’ll let you know what happens.

Thanks again.


I was able to upgrade the firmware to 01.01.18A, by connecting to a XP machine (in MSC mode), and using the Sandisk Updater. I then was able to access Settings\USB mode. There, I placed the CLIP into MSC mode. When I connected the CLIP to my VISTA machine, it once again, asked me to install drivers. I made sure all cables were firmly plugged in and tried again. Same result. I then formatted the device and to set the mode to MTP. Same result. One more reformat and an USB mode of auto detect, again, same result. Help please, before somone at Best Buy has to deal with an unhappy customer.


Hi there,

You said you run Vista and WMP10?  That’s really odd because Vista should be default with WMP11…if you mistyped it, it’s okay…but if it’s correct, then you need to have WMP11 on your Vista…try uninstall your WMP11 and reinstall again…or try to go to device manager, uninstall the device and plug in PC again to see if these two tricks work.

this is classic uninstall, reinstall… make sure clip shows up w/drive letter in my computer (or whatever vista calls it) to confirm msc status…if this doesnt fix it, i wanna know what does…as for the price, i paid 35$± for 2GB… that seemed good to replace my full size ipod as a daily user that can also rec FM on the fly and sound awesome w/great batt life…
dont stress, whatever it is, the fix is simple…

Message Edited by amkoas on 01-02-2008 09:08 AM

Ok, pretty much there is a driver that is available only through Microsoft’s website.  What you guys need to do is send a request to Microsoft for this driver and it should help to make your Clip work perfectly fine with the Vista system.  Go here and follow the instructions:;[LN];1414&from=KBHotfix&WS=hotfix

I hope this helps you guys out!


I bought Sansa clip (mp3) and my pc (windows vista) doesnt recognize it. I have tried everything. I can not add music and I cannot manage my mp3 through my pc…what can I do?

thanks a lot

What did you try?  A different USB cable?  Other USB ports?

Did you try connecting in MSC mode (Settings/USB)?  Did you try forcing MSC mode in connecting (Clip on hold, and pressing the center button down as you connect)?