Hang up's and freezes when copying, moving and transferring photos

Has anyone experienced long delays or hang up’s when trying to copy, move or transfer photos? Doesn’t seem to happen on office text type files, mostly happens with photos.

if I select a dozen photos from my IOS photos library (for example) and then try to move them to a new folder on the iXpand drive it seems to start copying them but then just Hang’s up or freezes.

I’m wondering if it is “looking” at my low-res photos on my iPad and then tries to download the high-res photos from my iCloud Photos Library and then gets hung-up.

any ideas or thoughts?  Thanks… Tom

IIRC the iXpand app does not access iCloud. From what I understand it only has access to the photos that are stored locally on the iOS device. I would try disabeling icloud and see if the issue persists. If so the issue would not seem to be related to iCloud. 

The iXpand app was just updated yesterday or the day before. the latest version is 1.6.1 If you have any thing older make sure you update the app. 

Thanks.  I’m going to do some further checking.  Although you may be correct re the iCloud Photos library I’m going to see what the “screen optimized” version that’s on the iPad versus the original version that’s in the iCloud Photos library (comparing file sizes).

Here are a couple of updates to my situation…

  1. I was using an iPad Air (1st generation) for my initial test where I had the hang up’s etc.
  2. I tried again just a few minutes ago with my iPad Pro (new) and had NO problems in regards to transferring, copying and moving.  Based on this, I’m going to go back to my iPad Air and try again.
  3. With the iPad Pro everything just happens faster.  The display of my IOS photos (30,000+) after you press the “+” button on the bottom of the iXpand screen took approx 1:25 to show on the iPad Air (A7 chip) versus only :31 to show on the iPad Pro (A9 chip and 4x the RAM).
  4. And yes - I am using version 1.6.1 of the app.  Versions prior to this would allows crash back to the home screen when I pressed the “+” button.
  5. I tried the iXpand on my Mac with public beta 7 of the latest OS and transferred, moved and copied files including the movie “Animal House” (2.5GB+).  The movie played perfectly on my iPad Pro - no stuttering - great picture and sound from within the iXpand app.