Getting files off the flash drive.

I have a Cruzer 64g USB Flash drive and I put a lot of pics on it just before my hard drive imploaded on my iMac. I have since then had a new hard drive put in and now I would like to take some of the pics off the flash drive and put them on my Mac so I can use them for different things. The flash drive will only let me see the pics in read only. I don’t know how to get them off the flash drive so I can use them. I have tried dragging them from the open flash drive to the desktop but nothing happens. The flash drive will let me drag things onto the flash drive to add them to the vault. TIA

:smiley:   Hi Cwokson,

Dear member of SanDisk Community, welcome.

Friend, there is nothing serious, it’s a compatibility issue.

Perhaps you have the Cruzer (UFD), SecureAccess version for windows.

There is another version for Mac.

See link:

Enjoy, and then you tell us, what happened, please.

Regards, Alfred.                                                              (Google translated)

After I moved a group of files into the encrypted space, they still have the same sizes but their filenames are encript style. When I try to open one, the system does not ask for my password, it just refuses to open. How can I open these encrypted files using my password? MY instrxion manual tells me all about how to get files encrypted, but now a word about how to open them!

:smiley:   Hi Davidandjodi,

Dear member of SanDisk Community, welcome.

Well, you should have in the Pendrive , two files:

1-   SanDiskSecureAccessV2_win, (the application, para abrir My Vault).

2-   SanDiskSecureAccess Vault, (which is the folder that contains the encrypted files).

I suspect that you are trying to run directly encrypted files. Therefore has problems.

3-   If you lost the application (v2), you can download (free, 7 MB) from here again:

4-   Please, read carefully the explanatory article.

5-   If you are still using (RunSanDiskSecureAccess_Win.exe), the version (v1), you can download (free, 29.3 MB) from here, and read the article:

Luck, and then you tell us, what happened, please.

Regards, Alfred.                                                             (Google translated)

I have downlowded the version for Mac. It will let me put new pics on and off of that vault, but I am still not able to move anything off of the original. I’m not able to transfer the pics on the RunSanDisckSecureAccess_Mac to the SanDisckSecureAccessV2_mac vault. Anymore ideas?

:smiley:   Hi Cwokson,


Regards, Alfred.                                      (Google translated)