G-Raid 2 12TB constantly falls asleep with Macbook Pro M2 (thunderbold 3 connection)

Recently bought a nice G-Raid 12 TB hard drive which is connected directly to a brand new Mac Book Pro M2. Unfortunately the drive constantly goes to sleep mode and shows me the famous mac windmill.

I bought it to work quicker than my older and way cheaper external usb harddisk but this only slows me down. Is this just a setting, does anyone know? I allready set the harddrives to constanty on in the Mac energy settings. Help, please!

1 Like

Hi @Digitalpunx,

Have you opened a Support Case? If not opened, for more information, please contact the SD Technical Support team for best assistance and troubleshooting:

Strange it happened to me too and I invested quite a bit of money and after consultation with an expert consultant!!

On the internet i see many cases with the same problem. First i set my harddrives (on MacbookPro M2) to always on but without result. Then i set my ‘turn screen of after … minutes’ to never. So far that solved the issue.

I even tried as an experiment to set ‘turn screen of after 1 hour’ and leave my mac for more than an hour, and yes … the problem was back again. A restart will do by the way :face_with_peeking_eye:

If your G-Raid 12 TB hard drive connected to your Mac Book pro M2 is frequently going into sleep mode and causing slowdowns. Ensure that the drive’s sleep settings are properly configured, either through the manufacture’s utility software or documentation. Adjust the Energy saver settings on your Mac to prevent the hard disks from going to sleep when possible. If you are using a USB connection, consider using a powered usb hub to ensure the drive receives sufficient power. It is also important to keep both the G-Raid drive and Mac firmware and drivers up to date.

If your G-Raid hard drive is going to sleep frequently and causing performance issues on your Mac Book Pro M2, there are a few potential solutions you can try:

Adjust power settings: As you mentioned, you have already set the hard drives to stay constantly on in the Mac energy settings. However, double-check the settings to ensure that the sleep settings are adjusted specifically for the external hard drive.

Use a different USB port or cable: Sometimes, connectivity issues can cause drives to go to sleep or experience intermittent disconnections. Try connecting the G-Raid hard drive to a different USB port on your Mac Book Pro or use a different USB cable to rule out any issues with the current connection.

Install manufacturer-specific software: Check if the manufacturer of the G-Raid hard drive provides any software or utilities for managing the drive’s settings. Such software may offer additional power management options or firmware updates that can help resolve the sleep mode issue.

Disable “Put hard disks to sleep when possible”: Go to System Preferences on your Mac, select “Energy Saver,” and make sure the option “Put hard disks to sleep when possible” is unchecked. This will prevent the Mac from putting the hard drives to sleep.

Use third-party disk utilities: There are various third-party disk utility applications available that allow you to customize power settings for external drives. These utilities may provide more granular control over sleep settings and help you prevent the driver from going to sleep unexpectedly.

Contact technical support: If none of the above solutions work, it’s advisable to reach out to the technical support of the G-Raid hard drive or the manufacturer for further assistance. They may be able to provide specific troubleshooting steps or suggest a firmware update that addresses the sleep mode issue.

Remember to always ensure you have a backup of your important data before attempting any changes or modifications to the drive’s settings or firmware.

The ONLY thing I have found that fixes this problem is in the app store (for mac, not sure about windows). The app is called “Amphetamine”. It will keep your drive from going to sleep. It’s a free download. When you download it, it will be an icon in the top right of your computer. Click on it, drop down to settings. Open the settings and go to “Drive Alive”. Click “Enable” then hit the “+” symbol and navigate to the drive you want to keep awake and select it. Make sure you check the box under the “Always Keep Drive Alive” tab.