Fuze not loud enough through stereo

My new Fuze is not playing loud enough through our new receiver.  My husband has the same Fuze and his plays just fine.  When my Fuze is connected (using the same cord and the same song from the same source) we have to crank up the sound on the receiver to nearly the max and sound quality is really poor.  Is it a lemon?  Do I try to take it back?

Go to Settings>System Settings>Volume and change it from “Normal” to “High”. If you don’t have a “High” setting, your region is probably set to Europe. The EU passed a law limiting the volume of electronic devices, so Sandisk removed the high setting for that region. Under System Settings, select Restore Factory Settings, then change the region to US or Rest of the World.

Thanks very much   cured my problem

…And here I was, expecting someone to metion something about replaygain.