Fuze+ microsd card not recognized?

Okay, so here’s my issue- I have an 8Gb Fuze+ that when I insert a Fat32 formatted microsd card, complains that there’s a filesystem error and to please reformat to Fat32. When I go to “format” under the settings menu, and try to format the card from there, it complains that it’s unable to detect any microsd card.

Gparted, new partition table, new fat32 partition, throw it in, same problem.

I tried just giving it a partition table and not defining any partitions, and seeing if i could format it then- same issue. I don’t have any other microsd cards to try to make sure it’s not the card, but needless to say, this card works flawlessly on my laptop through an adapter to full SD card size, which then goes into a built in card reader. It also works perfectly in my LG phone, so I doubt it’s anything to do with the card itself.

Google has offered no solutions, first place I checked. Looking around here on the forums and the support page didn’t yield any hints, either.

I updated the firmware manually (I’m on an Ubuntu Linux system), same issue. I got all excited, too, because the release notes for the 1.30.01 X firmware said it fixed a couple issues pertaining to sd cards not being recognized. But no dice- exact same issue, no change. Rebooting the Fuze+ doesn’t help either. When the card is in the device, and the device is plugged in, Ubuntu auto-mounts the Fuze+ and the card, no problem, and I can read and write successfully to both.

I did check permissions of the card, just in case (I know next to nothing about filesystems here, but hey, a “chmod 777 -R” can’t hurt, right?), and that’s not the issue.

I’ve looked about, made sure the songs on the card weren’t showing up despite the errors, and they weren’t- I made sure to make a similar directory structure as on the Fuze+ itself on the card, no luck that way either.

So now I turn to the forums- Is there any help to be had? Am I alone in experiencing this issue? Am I just doing something wrong, or is my device permanently sick?



An update:

I was able to get my hands on more properly working microsd cards- none worked in the Fuze+.

Pretty much expecting to return this within the next few days. :cry:

You may just have a bad unit. I have a 16gb card in my Fuze+ that works perfectly.

Hi Mike,

I have exactly the same problem. I have a 16Gb Trancend Class 2 uSD card (and 16Gb Fuze+) which can be read and written over USB by the player itself. Due to that I came to the conlusion that player and SD card are ok but the firmware of the player is buggy.

Some time ago I wrote some firmware for SD card access on ARM controllers. Stuff like USB MSC you got out of the box. No talent needed but to use an SD card in your own application is much more difficult. Different SD card have different timeouts - unluckily SD card specification doesn’t specify how to handle this in a proper way.

I just got this player for christmas, and I popped my 8gb uSD card out of my old Fuze (which is now dead) and popped it into the Fuze+.

When booting it says error reading uSD card, format it as Fat32 (it already is), and when I try to re-format it from the player, it says no uSD card detected, even though I can access it over usb from my computer.

I guess the firmware still needs some work…

You can format the microSD or SDHC card when the player is connected to the PC USB port only.  The Fuze+ Format command only formats the Internal Memory.

Do you have a card reader to check the card directly on your PC?

Bob  :dizzy_face:

Oh hey, I didn’t see I got a response to my post.  My computer doesn’t have a SD card reader, but the computer can see the uSD card through the usb connection with the player.

I was waiting until new firmware came out in hopes that it would fix this issue, but the one that came out a couple days ago didn’t change it.  I’ve tried formatting it in both linux and windows (while the player is plugged into the usb port).  Neither changes the error messages I’ve seen, even though it looks properly formatted on the computer.

I tried the 16GB microSD trick. Didn’t work. Called tech support, spent over an hour with her. She got me through updating the firmware and checking different size microSDs on the Fuze+ and other devices. Bottom line the 16GB doesn’t work in the Fuze (“FORMAT fat32” deal). I have a support number and was told it will be fixed and someone will get back to me within 48 to 72 hours. Stay tuned.

Any updated advice on this problem? I just bought a 16gb Fuze+ to replace my old 8gb Fuze. Trying to use a Sandisk 16gb micro SD card. I get message “File System error! Please format the uSD card to FAT32” and when I go to the settings menu to format the card, I get " No uSD card found".

Even though the SD card showed that it was already formatted as FAT32, I reformatted using my PC. I’ve scanned the card for errors and found none. I can also drag and drop from the Fuze+ internal memory to the SD Card (with adaptor, not inserted in Fuze+) using my PC with no problems.

When I connect the Sansa Fuze+ to my PC I can go to My Computer and am shown both internal AND external storage (sometiomes) however any attempts to drag and drop onto the SD Card while it’s in the Fuze+ receives an error message that the files can’t be copied (no reason given).

I have updated the Fuze+ to the most recent firmware.

Any solutions found yet?

Do you have the latest firmware for the Fuze+?

Yes, as stated in my original post: “I have updated the Fuze+ to the most recent firmware.”


I did that yesterday and I ran the Sansa Updater again today just to be sure there were no more firmware updates available.

Hi, i have an Fuze+ 4GB und bought me an sandisk 8GB micro sdhc card and get the same error messages. But when i use the usb-micro sdhc adapter thats worked on my pc, only the fuze+ cry thats the format was wrong. when i use the integrated formation tool i get the error: no usd card found. newest firmware is allready installed, checkdisk was OK. any sollutions? thanks for support

Time to call for Godzilla.

Here is a handy link for theSD Card Formatter Utilityfrom the SD Association.  Bet you didn’t know such an entity existed!  The problem with unrecognized cards may be that the Secure Digital part of the card is corrupted.  Normally, this is a reserved area, but weirder things have happened, right?

As a footnote, normally formatting from Windows should be just fine, but try this utility if there are any issues with your microSD card.

The microSD card can be mounted in the Fuze+ with the device powered up.  You will note that the device will begin reading the card as soon as it is mounted.  Now go and load that puppy up with your favorite music and videos!!

Bob  :smileyvery-happy:

hi bob, thanks for reply. i use this software, but this workaround dont work. i get allways the error message: “File system error! Please format the uSD Card to FAT32” why can windows handle this card without problems? iam the only one with this problem… omg the fuze+ was not a week old and the micro sdhc card three days. need the fuze+ a special cluster size or standard?(i use standard)

Hey there, I just got my Fuze+ in the mail today and I’m having the same problem with my 16gb microSD. I tried formatting it in both the player and in my card reader and got no results. I also have the latest firmware. I’m gonna have to call tech support I guess and see what they can do. I’ll keep you posted and let me know if anyone here figures this out. Thanks!

I am having the same problem. 16GB Sandisk microSDHC card. 8GB Fuze+. Latest firmware as of 3/31/11. Any updates from Sandisk? I tried a 4GB microSDHC that I have in my Blackberry Bold and that reads just fine. That is also a Sandisk microSDHC card.

As an update to my original post, I tried formatting the card both using a uSD to SD adapter in a laptop, as well as through the Fuze+ in MSC mode. I tried exFAT, NTFS, and FAT32 (4 byte through 64 kbyte allocation units) and nothing helped. I even tried formatting the card using the SD formatter mentioned previously in this post. I think it’s funny that the manual shows a 16GB uSD card in the picture.

Not saying this is it, but there have been a lot of 16 & 32GB counterfeit cards sold the last year or so. These are primarily coming out of China and are being sold at unbelieveably low prices on eBay and other similar on-line sites.

You can check the cards with the free h2testw utility.

Definitely try the h2test utility Tapeworm recommends, to see if the card is OK.  There are plenty of bogus cards out there, what they do is write a fake directory on the card (the SD Formatter rewrites part of this area).

As for cluster allocation, the Sansa does great with 32kb clusters , as opposed to Windows’ tendency to favor 4kb.  The smaller size causes some serious overhead in reading from the card.

Bob  :smileyvery-happy:

i tried this Tool (h2testw), its say there are no Errors. i also Format the uSD Card with 32kb Cluster Size, the same error. With the MicroSDHC to USB Adapter the Card works fine. When I Plug the Card with the Fuze+ i get allwas the same Error Message on Fuze. when Connect the Fuze+ to my Computer i can write any Data to this Card there no Problems, but after disconnect from the pc i get this error. i dont know!?! i think this card has no Errors, i think thats the Player! what do you think?