Fuze frozen after firmware update

I got 8GB Sansa Fuze as a present last week. I loaded it with my favorites… it worked fine.

Just now I connected it to computer downloaded SansaUpdaterInstall.exe and it installed update for firware and media converter.

Fuze showed that its installing new firmware… and everything was fine untill I watched a video on it and connected to a usb.

But it never did connect… it only is showing 4 colored petels and stays that way.

Is there a way to reflash firmware to previous version?

You can manually restore to any version.

Look at this page under ‘MSC mode instructions’: Sansa Fuze Firmware Update 01.02.26 & 02.02.26

Edit: changed link to firmware 0x.02.26.

Message Edited by 7o9 on 12-11-2009 02:45 AM

The update may have switched the USB mode to Auto Detect. And when you downgrade it will do the same.

Go to Settings/System Settings/USB Mode and try MSC or MTP. One of them will probably be the same as your previous connection. 

Thank you guys,

I could not load the fuze to get to USB mode. 

So, removed microSD card and restared 2 times - that worked.

After getting to USB mode and doing back to fuze02.02.26 it works fine.