Fuze+ clock works only if device is switched on

When the Fuze+ is switched on, the clock works correct (I adjusted correct time and date). When device is switched off, internal clock stops. When I again power on the Fuze+ time is incorrect (slowed).

What is wrong? Device or software?

Firmware: 02.37.01A

I don’t know whether the clock problem is universal, but there are a number of us who have this problem.  The clock on mine used to work properly, but it stopped doing so a couple of firmware revisions ago, and it has not been fixed.  Namely, the clock will keep proper time as long as the Fuze+ is on, but when the Fuze is restarted after being off, it reverts back to the same time that you last set it for.  I finally decided to set it for March 1, 2011 at 0:00.  With that setting, I can at least keep track of how long it has been turned on.  I have a decent watch, so I don’t really need it to be a timepiece.  As long as the sleep timer works properly, I can live with its otherwise “flaky” clock behavior until they get around to a firmware release that fixes it.

Uff… Thanks a lot for your answer!

I thought that device is damaged and should be replaced (usually clock is the functional base in electronic devices).

In my opinion it would be good to correct this bug in new releases of firmware - or add new function - “hide wrong clock” :smileyvery-happy:

Somebody (like me) thinks: “if clock is wrong, what else is wrong in Fuze+?” :smiley:


Your idea to use it as Fuze + work timer is excellent. Heh.

Mine didn’t work last firmware but works now in 02.37.01A. Try reapplying the firmware update and see if it fixes it.

I have tried reinstall firmware using manual method (copying firmware file directly to root folder on device). Unfortunately no changes :cry:

weird how it works fine fore some and not for others.Or in my case didn’t work last firmware and works in this one…

and now mine stopped working.

Just go to settings & select reset to factory settings then select yes

Reset to factory setting not resolved this problem - clock is still wrong :cry:

That’s weird I never had any problem with the clock and still no… very strange indeed…

i am also experienceing this; shouldn’t the time/date feature be a no-brainer to right? it worked before… whith whatever OS ver i had?  irritating

happens to me too, lastest firmware

I also thought  that device is damaged and should be replaced. :robotvery-happy: 

@jackblack1 wrote:

I also thought  that device is damaged and should be replaced. :robotvery-happy: 

I also thought trolls lived under bridges and don’t have internet access. :stuck_out_tongue:

Me too, having the clock prob!

Is this the same clock problem: http://forums.sandisk.com/t5/Fuze/Fuze-won-t-keep-time/td-p/152422

Thanks in advance :smiley:


My player’s clock is working good now. I think its caused my player was not fully charged before first run.

See manual next time :stuck_out_tongue: 

Count me in

i have the bug too

Factory reset didn’t help either

Charge it even when battery is full. I think there is some internal battery which is charging after the main battery.

I had prob with clock not running or running but losing abt 3 minutes between power cycles. I called Sandisk & got an RMA and was ready to ship back for warranty replacement.

As a last ditch effort, I reflashed with latest firmware (manually), then restored to factory default settings, reformatted the internal memory, set the clock and reloaded my music. Two days later; the time is correct, it stays correct and does not become incorrect after connecting/disconnecting to my linux box.

With everything working fine I am not willing to “experiment” with my Fuze but I think the methodology used to set the clock and then how you exit the Set Clock menu item determines whether you will be successful. 

All is well here.


overcharging it for 7hours did nothing. I’ll try this crazy reset schme and report back tomorrow.