Fuze+ clock works only if device is switched on

it might be a good idea to state what time format your using too ?

I always use the 12 hr clock and not the 24 hr clock

Im pretty sure this bug popped up on this 2.38.06 version

because i had checked the time before and it was never wrong…

I’ve installed (and still have) the following firmware,





fuzeplus02.38.06 <- current in use

XPmule it didn’t show in latest only I’ve had it for 4ish revisions. 12Hr clock.

Well, I finally got my clock to keep time.

I deleted the audiobooks I’d borrowed using Overdrive and then set the clock to the correct time.  Then, with the fuze+ connected, in Media Player’s sync tab, I clicked refresh devices (In MPs/ Settings/ Privacy Tab, I have ‘Set clock on devices automatically’, ticked).

I’m guessing that it was something to do with Overdrive’s DRM, to stop me extending my borrowing period by resetting the clock, so it may have worked without refreshing in Media Player. Anyway, so far, so good.

Edit: I should add that I also deleted the audiobooks from my computer, using ‘Delete’ on the OverDrive Media Console.