Frozen and not showing on MAC

  1. Frozen in sansa welcome mode

  2. Not showing on my MAC

  3. This is 2nd sansa clip to freakout. ugh… It got such good reviews on cnet, etc…

So I’ve tried following the directions to force it into MSC mode: slide the power button back into HOLD mode and press-n-hold the center button while plugging in the PC.

It’s still not showing on my mac 10.4.11. So i’m not able to format the stupid thing.  Any advice? Can i somehow dig into the device with some special powers of my mac? Or is it possible i’m not pushing the right button combo to get the contraption in MSC mode.

If i’m able to unfreez i’ll update the firmware asap. Does the new FW have the updates ‘click’ was pointing out in earlier posts on ID3 issues?


Did you try resetting?  Hold/on switch held in the uppermost position for 15-30 seconds.

So, when I push the power switch upward for about 5 seconds it’ll turn off, is this ‘resetting’? 

No, that’s turning it off.  Continue holding for 15-30 seconds to reset.

Alright, so i ended up returning it for the 2nd time.  This time i’m going to update the firmware right away, so hopefully this won’t happen again. 


Ugh… I figured out why my computer wasn’t recognizing my CLIP,  my mac had probably registered a USB error, and wasn’t allowing it to mount.  I took back the unit got a new one and it wasn’t mounting, so I took that one back, and got #4, and it didn’t mount. 

Then checked out click’s posting:

So i turned the computer off and on and it showed it, and updated the new firmware asap!  

Looking forward to this thing working smoothly. 

Cool, glad you figured it out. MACs are incredibly user-friendly, but something like a USB error should throw an error screen (it probably does appear in the console log). I suppose that pollutes the “it just works” mantra but I’d rather know WHY I need to reboot. /rant 

To answer the question in your OP, yes the latest FW (.20) does resolve the id3 tag / database refresh issue, but there are still some genre (mebbe other tag fields as well) replication issues if you have mixed tag text encodings and/or have both MP3s and WMAs on the Clip. From what I’ve heard, the next release (due out this week or next) will possibly fix this as well.