Firmware update R211 released for SanDisk Extreme SSD

Download SSD Toolkit (version (18MB)
Release notes for R211

Download and ins tall the SanDisk SSD toolkit. Once installed you can use the update tab to update the firmware of your SSD. For instructions see the SSD toolkit help file. 

New changes since version R211:

  • Improved TRIM Latency, TRIM Performance, Background Garbage Collection, Error Handling and Power Management
  • Fixed the normalized value calculation for SMART Attribute “Power-On Hours”.
  • Fixed an issue where temperature reading was not reporting correctly.

Known issues:

  • None
1 Like

Wow, I just happen to have checked the web page for the Extreme and see R211!

Thanks! I will try that this evening.

I’ve not followed the specifics of the problems w/ TRIM support. By installing R211, will any uncollected garbage and other errors from R201 be automatically resolved? Or do I need to do a secure erase and restore from a backup to realize all of the fixes in R211?

From what I understood, TRIM was still working, but the controller was just not as fast as before to clean the trimmed cells.

So it should be all right. Just upgrade as I did, no issue.

Updated on Mac and PC, no issues. Thank you for a painless firmware update!

I was able to upgrade with no issues so far. I have 3 SSDs of different brands (SanDisk, Patriot, Corsair) and each is updated differently. SanDisk required a reboot into Linux while at least one of the others allowed the update directly from Win 7.

Updating in windows is not as reliable as with a bootable disc. Windows can have different drivers, and all version of windows, this can affect the success of the update.

Yet, They work fine from windows with very few reported issues.

Correct answer is…  Making a linux boot disk is the least path of resistance when it comes to cost and time…

Those other brands like Intel and Samsung also have beautiful Windows based tools that do so much more than show smart info amd make a boot disk…   that requires hiring windows programmers and expensive development…

Yet another great firmware update from SanDisk. That makes it sound like there are many, no, only two.

There is something that I must mention that I have never before seen work correctly in a FW update for a SSD. While I was preparing the update, I remembered that my SanDisk EX 120GB SSD was connected to the Marvell 9128 SATA III chipset, not my boards standard Intel SATA chipset. No other SSD FW update I have performed (I have done many) would work or even detect the target SSD when connected to a secondary SATA controller. I am also using the standard Marvell AHCI driver (latest version) on the Marvell chipset.

My first reaction was, “Oh great, I need to change the EX SSD to the Intel SATA ports”. But then I thought I would see what happens with the SSD on the Marvell controller, so I booted into the update tool. Sure enough, the tool detected and chose the EX SSD. I proceeded with the FW update, and it seemed to finish fine. The PC shutdown when I exited the tool, and I booted into Windows. I checked the firmware on the EX SSD, R211 was installed. The FW update worked perfectly on the Marvell SATA controller and driver pair.

I’m impressed that SanDisk was able to have their FW update tool work on the secondary SATA controller. Any other FW update tool requires the SSD to be connected to the primary SATA controller. IMO, this indicates the high quality of SanDisk’s work. Great job programmers, and everyone involved with this update!

@jmbissell wrote:

I’ve not followed the specifics of the problems w/ TRIM support. By installing R211, will any uncollected garbage and other errors from R201 be automatically resolved? Or do I need to do a secure erase and restore from a backup to realize all of the fixes in R211?

Very difficult to know what affect the earlier (SandForce sourced) firmware TRIM problem had on the deleted files on your SSD.

Let’s assume that some of them were not cleaned up. The new firmware will be unaware of the deleted files, and WIndows 7 only sends a TRIM command for a deleted file once. Those deleted files will eventually be cleaned up by garbage collection, and it is not a big disaster to have a few files in that state on a SSD.

Still, we don’t know how bad this issue affected a normally used SSD. The “torture tests” used to detect the TRIM bug are nothing like the way a SSD is typically used. The tests would fill the SSD completely with data files, and then delete some of them, and write and delete them again over and over continually, keeping the SSD filled to capacity. Then the SSD would be formatted, deleting all the files, which will trigger TRIM commands to be sent to the SSD for all the files. Benchmark tests were compared before and after the torture tests, and showed that performance was not immediately restored.

If you want a clean start, a SE and restore from a backup would be the best way to go. But without doing that, you will have all the benefits the new FW has as soon as it is installed. TRIM simply works better now, but the firmware cannot make up for mistakes of the past.

1 Like

That’s actually not the way it was found.

If you want to see an increase right away then back your data up, SE the drive and put the data back on. I personally like Acronis for the task. 

That is true of course, you are correct, I am wrong (I’m telling you??)

I was confusing the TweakTown and RWLabs method of fill testing SSDs and the affects of TRIM, with the method that Anandtech tested TRIM in RAID 0. Unrelated, but both on my mind.

BTW, nice work finding and documenting the SF 5.0 firmware bug, still astounding to me it could slip past LSI/SF. You found it initially I imagine, as part of your usual SSD testing, which is described in the link in your post above.

It’s also curious IMO that TweakTown and RWLabs were the first and apparently only PC review web sites that published articles about this topic (I chatted about that a bit with Jon C.) That provides some insight into the true intended “customers” of those two web sites, in contrast to the others, IMO.

Parsec, you sir, are a good man.

I really just wanted to say it once but I’ve read several reviews on Anandtech and their fill test is different. they tends to seperate reads and write or percentage of read and writes, but the amount of files written to it, only around 10-20 gb? this may have larger effects on smaller drives ie 64/128 gb SSD but not so much on the 256 version.

imo what Chris and Jon are doing they literally have the drive filled up 25 50 and to 75% and then run vantage on all situaion, as explained in the article.  compressed or incompressed, this is probably by far the most accurate way of doing it.

Thanks unityole, I did not see your response until now.

I agree with your comments about the SSD fill tesing with Vantage done by Chris and Jon, which while seemingly simple compared to Anandtech’s tesing, is really a more real world test for most SSD users. It is also a basic lesson in SSD performance that many SSD users need. As you fill up and use a consumer/client SSD, its performance goes down. A simple reality that escapes many SSD owners. SSD performance does not remain the same as day one, empty,  Fresh Out of Box performance.

HDDs suffer from a generally similar performance decrease as they are used, but I never see users complaining about that.

I can’t update my Macbook Pro (MacBookPro6,1), I don’t have the optical drive installed as I have two disks.

I tried using reFit to boot from a CD and a USB drive with the image written to it, but I always get the same error coming back.

Error: Not found while loading legacy loader

Has anyone managed to update a MacBook with an external USB optical drive or Pen Drive?

external USB CDROM do not work. you will need to put the internal CDROM back in it or move the SSD to a different computer and do the update from there. 

thx drlucky.

Maybe one day we’ll have the SanDisk tools for the Mac, life will be so much easier… Just the through of having to rip macbook apart for each new firmware version is super dull.

And super super super dull when you have to take a Mac Mini apart.

There is no way to boot linux on a 2011 Mac Mini without major hacking (and even then I haven’t managed to get it to work), so you have to dismantle the machine to get the SSD out, just to do a firmware update.

PLEASE Sandisk, update your tool to run on OSX.  Would that be so freaking hard?  It would save 1000’s of your customers a whole load of pain.

I have bought tree disk for sagenext, which I too agree bcoz i did it but finallly i have to replace sandisk extreme SSD according to replacement process.

My firmware update fails. I put the 240 Extreme in a lenovo with the disk temporarily replaced by the SSD. The update menu comes up and finds the SSD but fails immediately. The error I see on the following screen is

Operation not permitted - 23 Inappropriate ioctl

a little lower says:

Download Microcode (MS 0) ATA result (129,0)

Anyone see something like this ? I’m booting from the CD I burned.  I tried it on two different Lenovo’s (all the windows boxes I have available to me).